hdu1085 Holding Bin-Laden Captive! (多重背包)

Holding Bin-Laden Captive!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 18710    Accepted Submission(s): 8329


Problem Description
We all know that Bin-Laden is a notorious terrorist, and he has disappeared for a long time. But recently, it is reported that he hides in Hang Zhou of China! 
“Oh, God! How terrible! ”



Don’t be so afraid, guys. Although he hides in a cave of Hang Zhou, he dares not to go out. Laden is so bored recent years that he fling himself into some math problems, and he said that if anyone can solve his problem, he will give himself up! 
Ha-ha! Obviously, Laden is too proud of his intelligence! But, what is his problem?
“Given some Chinese Coins (硬币) (three kinds-- 1, 2, 5), and their number is num_1, num_2 and num_5 respectively, please output the minimum value that you cannot pay with given coins.”
You, super ACMer, should solve the problem easily, and don’t forget to take $25000000 from Bush!
 

Input
Input contains multiple test cases. Each test case contains 3 positive integers num_1, num_2 and num_5 (0<=num_i<=1000). A test case containing 0 0 0 terminates the input and this test case is not to be processed.
 

Output
Output the minimum positive value that one cannot pay with given coins, one line for one case.
 

Sample Input
  
  
1 1 3 0 0 0
 

Sample Output
  
  
4
 

Author
lcy
 

Recommend
We have carefully selected several similar problems for you:   1171  2152  2082  1709  2079 
 


代码:

#include<cstdio>
#include<cstring>
#define ms(a) memset(a,0,sizeof(a))
using namespace std;

const int maxn=8e3;
int a[]={1,2,5},s[4];
bool f[maxn+10];

int main()
{
  freopen("1.in","r",stdin);
  
  int i,j,k,len;
  while(scanf("%d%d%d",&s[0],&s[1],&s[2]),s[0]+s[1]+s[2])
    {
      if(s[0]==0)
        {
          printf("%d\n",1);
          continue;
		}
      len=s[0]+2*s[1]+5*s[2];
      ms(f),f[0]=1;
      for(i=0;i<=2;i++)
        for(j=1;j<=s[i];j++)
          for(k=len;k>=a[i];k--)f[k]=f[k]|f[k-a[i]];
      for(i=1;i<=len;i++)if(!f[i])break;
      printf("%d\n",i);
	}
  return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值