关闭

NDK学习历程

1307人阅读 评论(0) 收藏 举报

关于6437 NDK的使用问题

首先介绍下我的开发平台,SEED-DEC6437,目的实现网口通信

已经从Ti 上下载了 NDK 1.93,查看spraax.pdf文档http://www.ti.com/litv/pdf/spraax4 ,才发现原来NDK有2部分

1)与平台无关的NDK,提供一些源码库文件头文件,提供的例程只有主要文件,无工程文件

2)与开发平台相关的NDK,提供例程所需的工程文件.

1,93 和2.0都支持6437 但是2.0所要求的Code Generator 版本高,无奈只有用了1.93

下载NDK的地址是这个

https://www-a.ti.com/downloads/s ... tent/NDK/index.html

需要注册ti的

里面并没有发现基于6437的NDK包,倒是6455/642*支持得很好。

后来摸索找找基于6437的NDK包,找到了

http://wiki.davincidsp.com/index ... ng_and_Availability

这里面指出需要下在psp-- platform support packages

地址在这里

https://www-a.ti.com/downloads/s ... bios_psp/index.html

到了里面看了之后

发现还需要前提条件

需要下载

1) EDMA3 LLD package installation (version 1.05.00 or later),

2) XDC tools installation (3.10 or later).

无奈2个都下了吧,也不知道是做什么用的,没细看release note

最后下载了BIOS PSP Release version 1.10.03这东西

解压后发现还真有 ndk for 6437,终于发现了里面的pjt,

可以问题接踵而至,首先是在client.pjt这个工程里,含有evmdm6437bsl.lib这个库没有找到,另外

或许是自己对ccs不熟练的原因,默认路径需要统统修改。

也因为含有bsl库,bsl是跟平台息息相关的,开始疑问到底seed的6437到底能不能适用NDK,

如果可以用,到底该用那个版本比较好,怎么搭建开发环境,谢谢

如果不能的话,只得还得看EMAC寄存器

0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:1473061次
    • 积分:20033
    • 等级:
    • 排名:第433名
    • 原创:27篇
    • 转载:1525篇
    • 译文:2篇
    • 评论:135条
    最新评论