POJ 1144 Network 求割点

Network
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 14235 Accepted: 6461
Description

A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbered by integers from 1 to N . No two places have the same number. The lines are bidirectional and always connect together two places and in each place the lines end in a telephone exchange. There is one telephone exchange in each place. From each place it is
possible to reach through lines every other place, however it need not be a direct connection, it can go through several exchanges. From time to time the power supply fails at a place and then the exchange does not operate. The officials from TLC realized that in such a case it can happen that besides the fact that the place with the failure is unreachable, this can also cause that some other places cannot connect to each other. In such a case we will say the place (where the failure
occured) is critical. Now the officials are trying to write a program for finding the number of all such critical places. Help them.
Input

The input file consists of several blocks of lines. Each block describes one network. In the first line of each block there is the number of places N < 100. Each of the next at most N lines contains the number of a place followed by the numbers of some places to which there is a direct line from this place. These at most N lines completely describe the network, i.e., each direct connection of two places in the network is contained at least in one row. All numbers in one line are separated
by one space. Each block ends with a line containing just 0. The last block has only one line with N = 0;
Output

The output contains for each block except the last in the input file one line containing the number of critical places.
Sample Input

5
5 1 2 3 4
0
6
2 1 3
5 4 6 2
0
0
Sample Output

1
2
Hint

You need to determine the end of one line.In order to make it’s easy to determine,there are no extra blank before the end of each line.

题目大意:给你一些双向联通的边,求割点的数目。
注意输入。

大概就是求割点的裸题,刚好拿来练板子了。
割点:对一个无向图来说,如果删除每个点u后,联通分量数目增加,则u就是图的割点。对于连通图,割点就是删除后使图不再联通的点。
依旧是如果low[v]>=dfn[u] 则u是一个割点。
注意要对根进行特殊的判断:只有当u有两个以上的子节点时,它才是割点。

代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

const int N = 100010;

int n;
int num=0;
int head[N];

struct node{
    int pre,v,u;
}edge[N];

void addedge(int from,int to){
    num++;
    edge[num].pre=head[from];
    edge[num].v=to;
    head[from]=num;
}

int indx=0;
int low[N],dfn[N];

bool iscut[N];

inline int Min(int a,int b){
    return a<b?a:b;
}

void Tarjan(int u,int f){
    low[u]=dfn[u]=++indx;
    int son=0;
    for(int i=head[u];i;i=edge[i].pre){
        int v=edge[i].v;
        if(v==f) continue; 
        if(!dfn[v]){
            Tarjan(v,u);
            son++;
            low[u]=Min(low[u],low[v]);
            if(low[v]>=dfn[u]){
                iscut[u]=true;
            }
        }
        else if(dfn[v]) low[u]=Min(low[u],dfn[v]);
    }
    if(f==0&&son==1) iscut[u]=false;
}

int ans;
#define ms(x,y) memset(x,y,sizeof(x))
void update(){
    ans=0,indx=0,num=0;
    ms(dfn,0);ms(low,0);ms(iscut,0);ms(head,0);
}

int main(){
    while(1){
        scanf("%d",&n);
        if(n==0) break;
        update();
        while(1){
            int u;
            scanf("%d",&u);
            if(u==0) break;
            while(getchar()!='\n'){
                int v;
                scanf("%d",&v);
                addedge(u,v);addedge(v,u);
            }
        }
        for(int i=1;i<=n;i++)
           if(!dfn[i]) Tarjan(i,0);
        for(int i=1;i<=n;i++)
           if(iscut[i]) ans++;
        printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值