关闭

linux编译VLC,常见错误

5899人阅读 评论(0) 收藏 举报
分类:

./configure: 
configure: error: C compiler cannot create executables
=>sudo apt-get install build-essential

error:BuggyGNU/libc (version 2.5 - 2.7) present. VLC would crash; there is no viable
work-around for this. Check with your distribution vendor on how to update the
glibc run-time. Alternatively, build with --disable-nls --disable-mozilla
=>sudo ./configure --disable-nls --disable-mozilla

 

configure: error: Could not find lua. Lua is needed for some interfaces (rc, telnet, http) as well as many other custom scripts. Use --disable-lua to ignore this error.
但我运行# yum install lua后提示:
Package lua-5.1.4-2.fc10.i386 already installed and latest version
后来才知道应当安装lua-devel,安装后解决了这个问题,后面的fribidi-devel小生也是这时候安装的)


error: Couldn't find DBus >= 1.0.0, install libdbus-dev ?
=> sudo apt-get install libhal-dev libdbus-1-dev

error: Could not find libmad on your system:...


libmad-0.15.1b.tar.gz

./configure

make

make install

 

error: Could not find libavcodec or libavutil...
=>sudo apt-get install libavcodec-dev

error: Could not find libavformat or libavutil...
=>sudo apt-get install libavformat-dev

error: Could not find libswscale...
=>sudo apt-get install libswscale-dev

error: Could not find libpostproc...
=>sudo apt-get install libpostproc-dev

error: Could not find liba52 on your system:...
=>sudo apt-get install liba52-dev

error: No package 'xcb' found

=>apt-get install libx11-xcb-dev 

error: No package 'xcb-shm' found

=>sudo apt-get install libxcb-shm0-dev

error: No package 'xcb-xv' found

=>sudo apt-get install libxcb-xv0-dev

error: Please install GL development package...
=>sudo apt-get install mesa-common-dev mesademos libgl1-mesa-dev libglu1-mesa-dev freeglut3-dev

... FRIBIDI ...QT4
=>sudo apt-get install libfribidi-dev libqt4-dev

装上qt以后还要还是让pkg-config可以找到qt4就可以了(/opt/qtsdk/qt/lib/pkgconfig) 
export PKG_CONFIG_PATH="/usr/lib/pkgconfig:/usr/local/lib/pkgconfig:/root/soft/ffmpeg/lib/pkgconfig:/root/soft/fribidi/lib/pkgconfig:/opt/qtsdk/qt/lib/pkgconfig" 

error: libgcrypt support required for RemoteOSD plugin
=>sudo apt-get install libgcrypt-dev

0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:289466次
    • 积分:2428
    • 等级:
    • 排名:第15807名
    • 原创:29篇
    • 转载:16篇
    • 译文:0篇
    • 评论:34条
    文章分类
    最新评论