关闭

java compiler level does not match the version of the installed java project facet 解决方法

标签: eclipseproject facetcompiler level
225人阅读 评论(0) 收藏 举报
分类:

错误如下:


1、Window->prefrences->compiler

2、点击下图Configure......,注意eclipse JDK版本,我这里是1.6,第二个红框

3、选择项目,点击OK


发现此项目的JDK为1.5,与eclipseJDK版本不匹配,如下图


如果左边复选框已选择,则取消左边红框的复选框,否则直接 选择与自己eclipse匹配的JDK版本,我这里选择1.6,如下图:


有时候到这一步,就已经解决问题了。

但是有时候还有错误,如第一个图。

右键工程  ,点击properties->Project Facets,将java版本改为对应的版本,我这里是1.6,点击OK,如下图。


错误已消失,如下图,大功告成。


0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:10300次
    • 积分:257
    • 等级:
    • 排名:千里之外
    • 原创:14篇
    • 转载:0篇
    • 译文:0篇
    • 评论:2条
    文章分类
    最新评论