zoj1003Crashing Balloon


Crashing Balloon

Time Limit: 2 Seconds       Memory Limit: 65536 KB

On every June 1st, the Children's Day, there will be a game named "crashing balloon" on TV.   The rule is very simple.  On the ground there are 100 labeled balloons, with the numbers 1 to 100.  After the referee shouts "Let's go!" the two players, who each starts with a score of  "1", race to crash the balloons by their feet and, at the same time, multiply their scores by the numbers written on the balloons they crash.  After a minute, the little audiences are allowed to take the remaining balloons away, and each contestant reports his\her score, the product of the numbers on the balloons he\she's crashed.  The unofficial winner is the player who announced the highest score.

Inevitably, though, disputes arise, and so the official winner is not determined until the disputes are resolved.  The player who claims the lower score is entitled to challenge his\her opponent's score.  The player with the lower score is presumed to have told the truth, because if he\she were to lie about his\her score, he\she would surely come up with a bigger better lie.  The challenge is upheld if the player with the higher score has a score that cannot be achieved with balloons not crashed by the challenging player.  So, if the challenge is successful, the player claiming the lower score wins.

So, for example, if one player claims 343 points and the other claims 49, then clearly the first player is lying; the only way to score 343 is by crashing balloons labeled 7 and 49, and the only way to score 49 is by crashing a balloon labeled 49.  Since each of two scores requires crashing the balloon labeled 49, the one claiming 343 points is presumed to be lying.

On the other hand, if one player claims 162 points and the other claims 81, it is possible for both to be telling the truth (e.g. one crashes balloons 2, 3 and 27, while the other crashes balloon 81), so the challenge would not be upheld.

By the way, if the challenger made a mistake on calculating his/her score, then the challenge would not be upheld. For example, if one player claims 10001 points and the other claims 10003, then clearly none of them are telling the truth. In this case, the challenge would not be upheld.

Unfortunately, anyone who is willing to referee a game of crashing balloon is likely to get over-excited in the hot atmosphere that he\she could not reasonably be expected to perform the intricate calculations that refereeing requires.  Hence the need for you, sober programmer, to provide a software solution.

Input

Pairs of unequal, positive numbers, with each pair on a single line, that are claimed scores from a game of crashing balloon.

Output

Numbers, one to a line, that are the winning scores, assuming that the player with the lower score always challenges the outcome.
Sample Input
343 49
3599 610
62 36

Sample Output
49
610

62

题目大意就是说,有100个气球,气球有编号1~100,有两个人,这两个人开始都是1分,让他们踩气球,踩破那个编号的气球,就让分数乘以编号,到最后,得分较高的人获胜,但得分较低者认为较高者作弊,分数乱报了,就检查较高者是否由出自己踩掉外的其他编号的气球而来,如果不是,则较大者作弊了,让较小者胜,最后输出胜者

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int oo,tt;
void dfs(int x,int y,int n)
{
	if(y==1)//如果b除到了1 
	{
	if(x==1)//同时a也除到了1;那么标记oo,说明较大者胜利,较大者没有说谎 
	oo=1;
	tt=1;//如果较小者除到了1;但较大者没有,说明较大者犯规. 
	}
	if(n>100||oo==1&&tt==1)//判断结束 
	return ;
	if(y%n==0)//先让较小者先除 
	dfs(x,y/n,n+1);
	if(x%n==0)
	dfs(x/n,y,n+1);
	dfs(x,y,n+1);//如果都除不了,进行下一个n 
}
int main()
{
	int a,b;
	while(scanf("%d%d",&a,&b)!=EOF)
	{
		if(a<b)//交换a,b的值保持a>b; 
		{
			int t=a;
			a=b;
			b=t;
		}
		oo=tt=0;//标记 
		dfs(a,b,2);//从2开始搜索 
	        if(oo==1)
            printf("%d\n",a);
        else if(tt==1)
            printf("%d\n",b);
        else
     printf("%d\n",a);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值