POJ 1328 Radar Installation

                                  
Radar Installation

                                      Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

   
   
Case 1: 2
Case 2: 1


思路:转化成区间问题,如果区间有相交叉的部分,说明有一个雷达就能覆盖,
如果,两区间不相交,说明一个雷达覆盖不了,只能再用一个雷达。这就成了
求区间上不相交的小区间个数了

#include<stdio.h>
#include<algorithm>
#include<math.h>
using namespace std;

struct point    
{
    double left;               //因为会出现小数所以定义为double型
    double right;
} a[1001];

bool cmp( const point x, const point y)
{

    return x.right<y.right;
}

int main()
{
    int n,d,t=1;
    while(scanf("%d%d",&n,&d)!=EOF)
    {
        if(n==0&&d==0)
            break;
        int i,count=0;
        double x,y,cur;
        int flag=1;
        for(i=0; i<n; i++)
        {
            scanf("%lf%lf",&x,&y);
            printf("%lf %lf\n",x,y);
           if(d-y<0)             //如果小岛所在的纵坐标大于雷达所覆盖的范围
                flag=0;           //计为0
            else if(flag)
            {
                a[i].left=x-sqrt(d*d-y*y);  //计算雷达离某小岛的最远距离的左右坐标
                a[i].right=x+sqrt(d*d-y*y);
            }
        }
        if(!flag)     //如果为0,说明不能完全覆盖,输出 -1
        {
            printf("Case %d: -1\n",t++);
            continue;
        }
        sort (a,a+n,cmp);  //对右坐标从小到大排序
        cur=a[0].right;     
        for(i=1; i<n; i++)
        {
            if(cur<a[i].left)   //如果左边的坐标(开始点)大于上一个区间的结束点坐标
            {
                count++;
                cur=a[i].right;
            }
        }
        printf("Case %d:\n",t++); 
        printf("%d\n",count);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值