【2017广西邀请赛】hdu 6186 CS Course

Problem Description
Little A has come to college and majored in Computer and Science.

Today he has learned bit-operations in Algorithm Lessons, and he got a problem as homework.

Here is the problem:

You are giving n non-negative integers  a1,a2,,an , and some queries.

A query only contains a positive integer p, which means you 
are asked to answer the result of bit-operations (and, or, xor) of all the integers except  ap .
 

Input
There are no more than 15 test cases. 

Each test case begins with two positive integers n and p
in a line, indicate the number of positive integers and the number of queries.

2n,q105

Then n non-negative integers  a1,a2,,an  follows in a line,  0ai109  for each i in range[1,n].

After that there are q positive integers  p1,p2,,pq in q lines,  1pin  for each i in range[1,q].
 

Output
For each query p, output three non-negative integers indicates the result of bit-operations(and, or, xor) of all non-negative integers except  ap  in a line.
 

Sample Input
  
  
3 3 1 1 1 1 2 3
 

Sample Output
  
  
1 1 0 1 1 0 1 1 0
 

题意:

求n个数,q个询问,求除了第p个数的&,|,^。

思路:

异或的话直接求出所有的数的异或,然后异或询问值。

与,或的话统计所有数每个位上的值。如果剩余数在当前位上的值大于0,则或值加上这个位的值。

如果剩余数早当前位上的值等于n-1,则与值加上这个位上的值。


//
//  main.cpp
//  1005
//
//  Created by zc on 2017/9/6.
//  Copyright © 2017年 zc. All rights reserved.
//

#include <iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#define ll long long
using namespace std;
const int N=110000;
int n,q,b[N][40],c[40],p;
ll a[N];

int main(int argc, const char * argv[]) {
    while(~scanf("%d%d",&n,&q))
    {
        ll ans3=0;
        memset(b,0,sizeof(b));
        memset(c,0,sizeof(c));
        for(int i=1;i<=n;i++)
        {
            scanf("%lld",&a[i]);
            ans3^=a[i];
            for(int j=0;j<33;j++)
            {
                if(a[i]&(1LL<<j))   b[i][j]=1;
                c[j]+=b[i][j];
            }
        }
        for(int i=0;i<q;i++)
        {
            scanf("%d",&p);
            ll ans1=0,ans2=0;
            for(int j=0;j<33;j++)
            {
                if(c[j]-b[p][j]==n-1)   ans1+=(1LL<<j);
                if(c[j]-b[p][j]>0)  ans2+=(1LL<<j);
            }
            printf("%lld %lld %lld\n",ans1,ans2,ans3^a[p]);
        }
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值