关闭

ZXing 4.7.4 编译的问题

346人阅读 评论(0) 收藏 举报
分类:

今天想研究下zxing,把源码下下来之后发现直接编译不了。     地址:ZXing


压缩包里有几个主要的文件:android,android-core,core。


首先将core拉到eclipse里,编译成Jar包。


接着将android拉到eclipse,将jar包导入,会发现提示缺失一个文件。


将android-core里的那一个类文件拉到android里的同名包里就行了。


接下来还是不行,里面包含了一些1.7以上的语法。


如果你升到了1.7,也可能会提示一个错误。


Using 1.7 requires compiling with Android 4.4 (KitKat); currently using API 15


研究了一番解决了,发现是sdk版本太低(眼瞎),然后右键项目名->properties->androids 选择4.4.2 或者以上的版本解决问题。

0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:6932次
    • 积分:150
    • 等级:
    • 排名:千里之外
    • 原创:6篇
    • 转载:0篇
    • 译文:2篇
    • 评论:2条
    文章分类
    最新评论