Gradle基础--认识Gradle

标签: androidgithubgroovyjavagradle
12604人阅读 评论(10) 收藏 举报
分类:

有人用android studio开发android项目,发现经常接触到Gradle,但是对它又不会有很大的关注,而当你的Gradle报错,或者从github,csdn上下载开源项目的时候,一旦出现gradle的错误,你就棘手了,所有我们还是很有必要去了解一下Gradle的世界。

什么是Gradle?

Gradle是一种依赖管理工具,基于Groovy语言,面向Java应用为主,它抛弃了基于XML的各种繁琐配置,取而代之的是一种基于Groovy的内部领域特定(DSL)语言。

Gradle的基本概念

下面就以我最近做的一个代表性的项目来详细讲解下和Gradle相关的知识, 和Gradle相关的几个文件一般有如下几个:
images
其中红色标记是我们今天要关注的内容。
首先简单的解释一下为什么会出现3个build.gradle。
在android studio里,每一个Project都会对应着一个build.gradle,他相当于eclipse里的workspace。
每一个Module都会自己对应一个build.gradle来分开管理,其中Module相当于eclipse对应的工程。明白了这个我们就逐个往下分析。

一、SnailBulb_Basic_Android/app/build.gradle

这个文件是app文件夹下这个Module的gradle配置文件,也可以算是整个项目最主要的gradle配置文件,我们来看下这个文件的内容:

//声明是android程序,这里是新版本的写法,老版本apply plugin:'androd'是同样的意思
apply plugin: 'com.android.application'

android {
    //当前编译版本
    compileSdkVersion 21
    //buildTools的版本号
    buildToolsVersion '21.1.2'

    defaultConfig {
        //程序的包名。以前eclipse是以AndroidManifest里为主,这里以gradle配置的为主,AndroidManifest里的无效
        applicationId "com.snaillove.app.snailbulb.general"
        minSdkVersion 9
        targetSdkVersion 21
        versionCode 121
        versionName "1.21"
    }
    buildTypes {
        release {
            //是否允许debug调试
            debuggable true
            // 是否进行混淆 minifyEnabled也是最新的语法,很早之前是runProguard,这个也需要更新下。在github上拉去项目经常会报这个地方的错误。一定要记得改过来
            minifyEnabled false
            // 混淆文件的位置
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
        debug {
            debuggable true
        }
    }
}

//本地依赖 下一篇会具体介绍
dependencies {

    // 编译libs目录下的所有jar包
    compile fileTree(include: ['*.jar'], dir: 'libs')
    compile 'com.android.support:support-v4:22.2.0'
    compile 'com.android.support:appcompat-v7:22.2.0'
    compile 'com.google.code.gson:gson:2.3.1'
    compile 'com.wunderlist:sliding-layer:1.2.5'
    compile 'com.nineoldandroids:library:2.4.0'
    compile 'com.astuetz:pagerslidingtabstrip:1.0.1'
    compile 'com.readystatesoftware.systembartint:systembartint:1.0.3'
    // 编译bDIntegrationSDK_LibProject模块
    compile project(':bDIntegrationSDK_LibProject')
}

这里需要说明几点:

1、文件开头apply plugin是最新gradle版本的写法,以前的写法是apply plugin: ‘android’, 这里大家注意一下。
2、buildToolsVersion这个需要你本地安装该版本才行,很多人导入新的第三方库,失败的原因之一是build version的版本不对,这个可以手动更改成你本地已有的版本或者打开 SDK Manager 去下载对应版本。
3、applicationId代表应用的包名,也是最新的写法,这里就不在多说了。
4、android 5.0开始默认安装jdk1.7才能编译,但是由于mac系统自带jdk的版本是1.6,所以需要手动下载jdk1.7并配置下,具体可以见我这篇博客Mac下安装和管理Java
5、minifyEnabled也是最新的语法,很早之前是runProguard,这个也需要更新下。
6、proguardFiles这部分有两段,前一部分代表系统默认的android程序的混淆文件,该文件已经包含了基本的混淆声明,免去了我们很多事,这个文件的目录在 sdk目录/tools/proguard/proguard-android.txt , 后一部分是我们项目里的自定义的混淆文件,目录就在 app/proguard-rules.txt , 如果你用Studio 1.0创建的新项目默认生成的文件名是 proguard-rules.pro , 这个名字没关系,在这个文件里你可以声明一些第三方依赖的一些混淆规则,由于是开源项目,SnailBulb_Basic_Android里并未进行混淆,具体混淆的语法也不是本篇博客讨论的范围。最终混淆的结果是这两部分文件共同作用的。
7、以上文件里的内容只是基本配置,其实还有很多自定义部分,如自动打包debug,release,beta等环境,签名,多渠道打包等,后续会单独拿出来讲解

二、SnailBulb_Basic_Android/bDIntegrationSDK_LibProject/build.gradle

apply plugin: 'com.android.library'

android {
    compileSdkVersion 21
    buildToolsVersion "21.1.2"

    defaultConfig {
    }

    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt'
        }
    }
}

dependencies {
    //compile 'com.android.support:support-v4:19.+'
    //单文件依赖
    compile files('libs/android_api_3.7.1.3.jar')
    compile files('libs/BDAutoUpdateSDK_20150605_V1.2.0.jar')
    compile files('libs/need_lib.jar')
    compile files('libs/patchupdate.jar')

    compile 'com.android.support:support-v4:22.2.0'
}

看了上面的讲解在看这个估计已经无压力了
每一个Module都需要有一个gradle配置文件,语法都是一样,唯一不同的是开头声明的是
applyplugin: 'com.android.library'

三、 SnailBulb_Basic_Android/gradle

这个目录下有个 wrapper 文件夹,里面可以看到有两个文件,我们主要看下 gradle-wrapper.properties 这个文件的内容:

Mon Aug 24 13:25:25 CST 2015
distributionBase=GRADLE_USER_HOME
distributionPath=wrapper/dists
zipStoreBase=GRADLE_USER_HOME
zipStorePath=wrapper/dists
distributionUrl=https://services.gradle.org/distributions/gradle-2.4-all.zip

可以看到里面声明了gradle的目录与下载路径以及当前项目使用的gradle版本,这些默认的路径我们一般不会更改的,这个文件里指明的gradle版本不对也是很多导包不成功的原因之一。
当你的gradle依赖更换的时候,这个路径是很容易报错的,需要你手动换过来。

四、 SnailBulb_Basic_Android/build.gradle

这个文件是整个项目的gradle基础配置文件,我们来看看这里面的内容

//对于buildscript{} 在android gradle是用来预置插件环境,一般不建议把依赖写着里面
//buildscript设置脚步的运行环境
buildscript {
    //repositories支持java 依赖库管理(maven/ivy),用于项目的依赖
    repositories {
        jcenter()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:1.2.3'

        // NOTE: Do not place your application dependencies here; they belong
        // in the individual module build.gradle files
    }
}

allprojects {
    repositories {
        jcenter()
    }
}

内容主要包含了两个方面:一个是声明仓库的源,这里可以看到是指明的jcenter(), 之前版本则是mavenCentral(), jcenter可以理解成是一个新的中央远程仓库,兼容maven中心仓库,而且性能更优。另一个是声明了android gradle plugin的版本,android studio 1.2正式版必须要求支持gradle plugin 1.2的版本。

五、 SnailBulb_Basic_Android/settings.gradle

这个文件是全局的项目配置文件,里面主要声明一些需要加入gradle的module,我们来看看SnailBulb_Basic_Android该文件的内容:

include ‘:app’, ‘bDIntegrationSDK_LibProject’
文件中的 app, bDIntegrationSDK_LibProject 都是module,如果还有其他module都需要按照如上格式加进去。

六、总结

看到这里你应该对Gradle有了一个基本的认识,希望以后你在报错的时候,或者从其他地方下载项目的时候,知道去哪里更改gradle配置啦。

个人博客

http://www.jackwaiting.com
https://github.com/Jackwaiting
http://www.zhihu.com/people/jackwaiting

5
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:247618次
    • 积分:2524
    • 等级:
    • 排名:第16352名
    • 原创:34篇
    • 转载:0篇
    • 译文:2篇
    • 评论:64条
    博客专栏
    文章分类
    最新评论