hdoj 1034 Candy Sharing Game

Candy Sharing Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4430    Accepted Submission(s): 2703


Problem Description
A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of his or her candy to the neighbor on the right. Any student, who ends up with an odd number of pieces of candy, is given another piece by the teacher. The game ends when all students have the same number of pieces of candy. 
Write a program which determines the number of times the teacher blows the whistle and the final number of pieces of candy for each student from the amount of candy each child starts with.
 

Input
The input may describe more than one game. For each game, the input begins with the number N of students, followed by N (even) candy counts for the children counter-clockwise around the circle. The input ends with a student count of 0. Each input number is on a line by itself.
 

Output
For each game, output the number of rounds of the game followed by the amount of candy each child ends up with, both on one line.
 

Sample Input
  
  
6 36 2 2 2 2 2 11 22 20 18 16 14 12 10 8 6 4 2 4 2 4 6 8 0
 

Sample Output
  
  
15 14 17 22 4 8
Hint
The game ends in a finite number of steps because: 1. The maximum candy count can never increase. 2. The minimum candy count can never decrease. 3. No one with more than the minimum amount will ever decrease to the minimum. 4. If the maximum and minimum candy count are not the same, at least one student with the minimum amount must have their count increase.
题意:
老师让n同学们做成一个圈,从1到n每个同学手中都有偶数数量的糖果,然后循环着每个人都把自己的糖果的一半个给下一个同学!如果在这其中有同学的糖果数目是一个奇数,老师会给该同学一个糖果! 这样循环直到全部同学的糖果数目相同!
输出 进行的循环的次数,和结束时同学们手中的糖果数目!
代码:
#include<stdio.h>
int  a[1100];
int  n;
int   judge()
{
	int  i;
	for(i=1;i<n;i++)
	if(a[i-1]!=a[i])
	return 0;
	return  1;
}
int main()
{

	while(scanf("%d",&n)!=EOF&&n)
	{
		int i;
		for(i=0;i<n;i++)
		{
			scanf("%d",&a[i]);
		}
		int num=0;
		while(!judge())
		{
			num++;
		int temp=a[n-1]/2;//先将最后一个糖果数目的一半记录,然后加到a[0]上面! 
		for(i=n-1;i>0;i--)//倒着进行糖果的转移! 
		{
		    a[i]=a[i]/2+a[i-1]/2;
		}
		a[0]=a[0]/2+temp;//加上最后一个数目的一半! 
		for(i=0;i<n;i++)
		{
			if(a[i]%2)
			a[i]++;
		}
	    }
	    printf("%d %d\n",num,a[0]);
	}
	return  0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值