HDU 1398 Square Coins(母函数)

11 篇文章 0 订阅

原题

Square Coins

Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u

Description

People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland.
There are four combinations of coins to pay ten credits:

ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin.

Your mission is to count the number of ways to pay a given amount using coins of Silverland.

Input

The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.


Output

For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output.


Sample Input

2
10
30
0


Sample Output

1
4
27

题意


用1~17的平方的面值的硬币来表示给出的金额,可以重复使用,问有多少种表示方式。

涉及知识及算法


母函数

代码

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int MAX_V = 300;
int C1[MAX_V];
int C2[MAX_V];
int v;

void solve()
{
    //C2为辅助的存贮
    memset(C2,0,sizeof(C2));
    //把第一个表达式的所有的系数初始化为1
    for(int i=0;i<=MAX_V;i++)
    {
        C1[i]=1;
    }
    //第2至第n个表达式
    for(int i=2;i<=MAX_V;i++)
    {
        //C1的数组实质上存储的是前i-1个表达式累乘后各个项系数
        //j是标识前i-1个表达式累乘后各个项的指数
        for(int j=0;j<=MAX_V;j++)
        {
            //k为第i个表达式中每个项的指数,若为第二个式子,则,第一
            //项为x^0,第二项为x^4,第三项为x^8,故步长为i*i
            for(int k=0;j+k<=MAX_V;k+=i*i)
            {
                //若前面i-1个式子计算后某项为ax^j(系数为a),
                //则乘法(ax^j)*(x*k)=ax^(j+k)可表示为C2[j+k]+=a=C1[j];
                C2[j+k]+=C1[j];
            }
        }
        //刷新为当前i个表达式累乘后各个项系数
        for(int j=0;j<=MAX_V;j++)
        {
            C1[j]=C2[j];
            C2[j]=0;
        }
    }
}
int main()
{
    solve();
    while(cin>>v&&v)
    {
        cout<<C1[v]<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值