activemq java版本要求

原创 2016年05月30日 11:53:00
<pre name="code" class="html">activemq:

redis01:/root# cp apache-activemq-5.13.2-bin.tar.gz /usr/local/

安装目录:
redis01:/usr/local/apache-activemq-5.13.2# pwd
/usr/local/apache-activemq-5.13.2

添加ACTIVEMQ_OPTS_MEMORY的配置为ACTIVEMQ_OPTS_MEMORY="-Xms256M -Xmx384M -XX:PermSize=256M -XX:MaxPermSize=384M"
/usr/local/activemq/bin/activemq start
netstat -lnp|grep 61616
完成后添加/usr/local/activemq/bin/activemq start到自启动
配置好后可以登录监控管理页面去看队列情况
 http://192.168.100.15:8161/admin/queues.jsp

默认用户密码 admin/admin

当前版本默认开启密码认证:
    <bean id="securityConstraint" class="org.eclipse.jetty.util.security.Constraint">
        <property name="name" value="BASIC" />
        <property name="roles" value="user,admin" />
        <!-- set authenticate=false to disable login -->
        <property name="authenticate" value="true" />
    </bean>
    <bean id="adminSecurityConstraint" class="org.eclipse.jetty.util.security.Constraint">
        <property name="name" value="BASIC" />
        <property name="roles" value="admin" />
         <!-- set authenticate=false to disable login -->
        <property name="authenticate" value="true" />


redis01:/usr/local/apache-activemq-5.13.2# vim  conf/jetty-realm.properties 

修改密码

需要的Java版本:
redis01:/usr/bin# rpm -qa | grep java
tzdata-java-2013g-1.el6.noarch
java-1.7.0-openjdk-1.7.0.45-2.4.3.3.el6.x86_64
java-1.6.0-openjdk-1.6.0.0-1.66.1.13.0.el6.x86_64



                    

Apache ActiveMQ 各个版本所依赖的JDK版本

JAVA版本列表 发布版本号 内部版本号(十进制) 内部版本号(十六进制) 1.5 31 49 1.6 32 50 1.7 33 ...

为activemq指定运行的jdk版本

在一个linux上配置了环境变量的JAVA_HOME是jdk1.6的, 而最新的activemq-5.14.3  运行/bin/activemq 会报错不支持这个版本的jdk,..............
  • lsm135
  • lsm135
  • 2017年01月05日 13:13
  • 4725

ActiveMQ使用步骤--- 开发测试环境搭建及Java用例

Linux 系统 ActiveMQ 版本:5.8.0 一、下载ActiveMQ5.8.0 ActiveMQ版本地址:http://activemq.apache.org/download-arch...

Delphi7高级应用开发随书源码

  • 2003年04月30日 00:00
  • 676KB
  • 下载

activemq发送和接收对象

1、首先,在这里确认一下版本,activemq版本是apache-activemq-5.4.1-bin.zip,activemq安装环境是win7,jdk是1.6版本。下载apache-activem...

ActiveMQ5.11.1和JDK版本的匹配关系

环境:MyEclipse2015+ActiveMQ5.11.1 使用不同版本的JDK,执行Java application时会出现不同的表现。 1、JDK版本为jdk1.5/J2S...
  • zxygww
  • zxygww
  • 2015年05月22日 18:50
  • 3644

在Eclipse中安装jar包到本地Maven仓库

org.apache.maven.plugins maven-install-plugin install install-fil...

导入自己的jar包到maven依赖库中

导入自己的jar包到maven依赖库中       mvn install:install-file -DgroupId=javax.jms -DartifactId=jms -Dversion=1...
  • lvyuanj
  • lvyuanj
  • 2016年07月06日 14:47
  • 3022

apache-activemq-5.14.5。windows版本

  • 2017年04月23日 17:46
  • 58.05MB
  • 下载

apache-activemq Linux版本

  • 2016年08月25日 02:04
  • 51.72MB
  • 下载
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:activemq java版本要求
举报原因:
原因补充:

(最多只允许输入30个字)