POJ 1050 To the Max

To the Max
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 49003 Accepted: 25928

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:

9 2
-4 1
-1 8
and has a sum of 15.

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15
思路:动态规划 最大子矩阵和  参见 点击打开链接

代码如下

#include<iostream>
#include<stdio.h>
#include<vector>
#include<algorithm>
#include<memory.h>
using namespace std;

int main() {
   // freopen("input.txt","r",stdin);
    int N;
    cin>>N;
    int mat[102][102];
    int dp[102][102];
    for(int i = 1; i <= N; i++) {
        for(int j = 1; j <= N; j++) {
            cin>>mat[i][j];
        }
    }
    memset(dp,0,sizeof(dp));
    for(int i = 1; i <= N; i++) {
        for(int j = 1; j <= N; j++) {
            dp[i][j] = dp[i-1][j] + dp[i][j-1] - dp[i-1][j-1]  + mat[i][j];
        }
    }
    int res = 0;
    for(int p = 1; p <= N; p++) {
        for(int q = p; q <= N; q++) {
            for(int r = 1; r <= N; r++) {
                for(int s = r; s <= N; s++) {
                    int rect = dp[q][s] - dp[q][r-1] - dp[p-1][s] + dp[p-1][r-1];
                    if(rect > res)  res = rect;
                }
            }
        }
    }
    cout<<res<<endl;
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

zhengjihao

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值