hdu 1001

Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.

Input
The input will consist of a series of integers n, one integer per line.

Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.

Sample Input
1
100


 

Sample Output
1


5050


读到题目的第一想法就是用数学公式 SUM(n) = (1 + n) * n / 2 ;但是,提交后却无法通过,后来才发现题目要求是32bit,但是 (1 + n) * n 可能会超出范围,所以先除以2,就得考虑奇偶问题。代码如下:


#include<iostream>
using namespace std;
int main(){
int n;
while(cin>>n){
if(n%2 == 0) //注意:题目要求不能超出32bit,但是n*(n+1)会超出范围,所以的先除2!
{cout<<(n/2)*(n+1)<<endl<<endl;}
else
{cout<<((n+1)/2)*n<<endl<<endl;}
}
return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值