HDU1078 FatMouse and Cheese DP(记忆化搜索)

FatMouse and Cheese

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11002    Accepted Submission(s): 4671


Problem Description
FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move. 
 

Input
There are several test cases. Each test case consists of 

a line containing two integers between 1 and 100: n and k 
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on. 
The input ends with a pair of -1's. 
 

Output
For each test case output in a line the single integer giving the number of blocks of cheese collected. 
 

Sample Input
  
  
3 1 1 2 5 10 11 6 12 12 7 -1 -1
 

Sample Output
  
  
37
 
题意:有个n*n的表格,一只老鼠开始在(0,0)点,每个点都有一些食物。老鼠每次可以水平或者竖直走最多k步,且下一个点的食物要比这个点的食物多。问老鼠最多能吃多少食物。
解析:因为n是100的范围,所以直接搜索会TLE,应该用记忆化搜索。dp[x][y] = max(dp[tx][ty])+a[x][y],其中(tx, ty)是能从(x, y)到达的下一个点,且如果这个点已经记录下它的dp值,可以直接用;如果没有记录,则从这个点继续往下搜索。
代码:
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
#define N 105
int a[N][N], dp[N][N];
int n, k;
int Next[4][2] = {{1,0}, {0,1}, {-1,0}, {0,-1}};
int dfs(int x, int y){
	if(dp[x][y] != -1) return dp[x][y];
	int Max = 0;
	for(int i = 1; i <= k; i++){
		for(int j = 0; j < 4; j++){
			int tx = x + Next[j][0]*i;
			int ty = y + Next[j][1]*i;
			if(tx < 0 || tx >= n || ty < 0 || ty >= n || a[tx][ty] <= a[x][y])continue;
			Max = max(Max, dfs(tx, ty));
		}
	}
	return dp[x][y] = Max + a[x][y];	
}
int main(){
	while(scanf("%d%d", &n, &k) && n+k!=-2){
		for(int i = 0; i < n; i++)
			for(int j = 0; j < n; j++){
				scanf("%d", &a[i][j]);
				dp[i][j] = -1;
			}
		int ans = dfs(0, 0);
		printf("%d\n", ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值