HDU 1251 统计难题 trie树

简单的p->count++

统计难题
Time Limit:2000MS     Memory Limit:65535KB     64bit IO Format:%I64d & %I64u

Description

Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀). 
 

Input

输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串. 

注意:本题只有一组测试数据,处理到文件结束. 
 

Output

对于每个提问,给出以该字符串为前缀的单词的数量. 
 

Sample Input

     
     
banana band bee absolute acm ba b band abc
 

Sample Output

     
     
2 3 1 0

#include <iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
using namespace std;
typedef struct Trie_node
{
    int count;
    struct Trie_node* next[26];
    bool exist;
}TrieNode , *Trie;
TrieNode* create()
{
    TrieNode *tmp=(TrieNode*)malloc(sizeof(TrieNode));
    tmp->exist=false;
    for(int i=0;i<26;i++) tmp->next[i]=NULL;
    tmp->count=0;
    return tmp;
}
void insert(Trie root,char *str)
{
    Trie p=root;
    while(*str!='\0')
    {
        if(p->next[*str-'a']==NULL)
        {
            p->next[*str-'a']=create();
        }
        p=p->next[*str-'a'];
        str++;
        p->count++;
    }
    p->exist=true;
}
int fnd(Trie root,char *str)
{
    Trie p=root;
    while(*str!='\0')
    {
        if(p->next[*str-'a']==NULL) return 0;
        p=p->next[*str-'a'];
        str++;
    }
    return p->count;
}
int main()
{
    //freopen("cin.txt","r",stdin);
    char str[20];
    Trie root=create();
    bool flag=false;
    while(gets(str))
    {
        if(flag) cout<<fnd(root,str)<<endl;
        else
        {
            if(strlen(str)) insert(root,str);
            else flag=true;
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值