2015亚洲网络赛上海站1010A Sweet Journey

Problem Description
Master Di plans to take his girlfriend for a travel by bike. Their journey, which can be seen as a line segment of length L, is a road of swamps and flats. In the swamp, it takes A point strengths per meter for Master Di to ride; In the flats, Master Di will regain B point strengths per meter when riding. Master Di wonders:In the beginning, he needs to prepare how much minimum strengths. (Except riding all the time,Master Di has no other choice) 

 

Input
In the first line there is an integer t ( 1t50 ), indicating the number of test cases.
For each test case:
The first line contains four integers, n, A, B, L.
Next n lines, each line contains two integers:  Li,Ri , which represents the interval  [Li,Ri]  is swamp.
1n100,1L105,1A10,1B101Li<RiL .
Make sure intervals are not overlapped which means  Ri<Li+1  for each i ( 1i<n ).
Others are all flats except the swamps.
 

Output
For each text case:
Please output “Case #k: answer”(without quotes) one line, where k means the case number counting from 1, and the answer is his minimum strengths in the beginning.
 

Sample Input
  
  
1 2 2 2 5 1 2 3 4
 

Sample Output
  
  
Case #1: 0
 


反正也是一个签到题,剧透一下也未尝不可嘛~~

#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int l[105],r[105],len,a,b,t,n;
bool vis[100005];
int main()
{
    scanf("%d",&t);
    int cas=1;
    while(t--)
    {
        scanf("%d%d%d%d",&n,&a,&b,&len);

        memset(vis,0,sizeof(vis));
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&l[i],&r[i]);
            for(int j=l[i]+1;j<=r[i];j++)
            vis[j]=1;
        }
        int sum=0,maxn=999999;
        for(int i=1;i<=len;i++)
        {
            if(vis[i]==0) sum+=b;
            else sum-=a;
            if(maxn>sum&&sum<0) maxn=sum;
        }
        printf("Case #%d: ",cas++);
        if(maxn>=0) printf("0\n");
        else printf("%d\n",-maxn);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值