关闭

python, pip版本问题解决

标签: pythonLinuxpip
1758人阅读 评论(0) 收藏 举报
分类:

1. pkg_resources.DistributionNotFound: distribute==0.6.24dev-r0

产生这类错误一般是因为使用的pip或easy_install版本与python版本不一致的问题, 即原来是python2.7的pip或easy_install, 现在你用来安装python3的相关程序

解决方法: (1)通过which easy_install 来确定是否是你真正想使用的版本

                  (2)删除或卸载之前本版安装的easy_install 和pip(pip 要用对应的python来卸载)

                 (3) 用对应版本的easy_install来安装pip: sudo python /usr/local/python3.3.2/lib/python3.3/site-packages/distribute-0.6.49-py3.3.egg/easy_install.py pip 

注:python 是链接python3.3版本

                  (4) 用pip安装其他python程序

0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:63814次
    • 积分:1154
    • 等级:
    • 排名:千里之外
    • 原创:50篇
    • 转载:30篇
    • 译文:0篇
    • 评论:3条
    最新评论