POJ 1129 Channel Allocation

Channel Allocation
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Description

When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a strong signal. However, the channels used by each repeater must be carefully chosen so that nearby repeaters do not interfere with one another. This condition is satisfied if adjacent repeaters use different channels. 

Since the radio frequency spectrum is a precious resource, the number of channels required by a given network of repeaters should be minimised. You have to write a program that reads in a description of a repeater network and determines the minimum number of channels required.

Input

The input consists of a number of maps of repeater networks. Each map begins with a line containing the number of repeaters. This is between 1 and 26, and the repeaters are referred to by consecutive upper-case letters of the alphabet starting with A. For example, ten repeaters would have the names A,B,C,...,I and J. A network with zero repeaters indicates the end of input. 

Following the number of repeaters is a list of adjacency relationships. Each line has the form: 

A:BCDH 

which indicates that the repeaters B, C, D and H are adjacent to the repeater A. The first line describes those adjacent to repeater A, the second those adjacent to B, and so on for all of the repeaters. If a repeater is not adjacent to any other, its line has the form 

A: 

The repeaters are listed in alphabetical order. 

Note that the adjacency is a symmetric relationship; if A is adjacent to B, then B is necessarily adjacent to A. Also, since the repeaters lie in a plane, the graph formed by connecting adjacent repeaters does not have any line segments that cross. 

Output

For each map (except the final one with no repeaters), print a line containing the minumum number of channels needed so that no adjacent channels interfere. The sample output shows the format of this line. Take care that channels is in the singular form when only one channel is required.

Sample Input

2
A:
B:
4
A:BC
B:ACD
C:ABD
D:BC
4
A:BCD
B:ACD
C:ABD
D:ABC
0

Sample Output

1 channel needed.
3 channels needed.
4 channels needed. 


题目大意:涂色游戏,相邻的不能涂同一颜色,  输入:  第一行给出一个整数代表下面字符串的个数,字符串的第一个字母代表开始的点, 与 : 后边的字符都相连, 注意此为无向图,最后输出最少可以涂多少种颜色,  一个不算坑点的坑点就是在输出的时候, channel   是不是复数,但这个细心一点就好,因为样例中出现过。

解题思路:其实这个题目很简单,就是从头开始遍历,第一个点先涂1, 那么与它相连的后边的点都不能涂1, 标记一下, 我是用了一个二维数组    co[字符] [颜色],  因为不能涂1, 所以颜色1 就标记一下,为1, 当然初始化都为0, 然后每次涂色之前,先判断可以涂哪个颜色,因为要求的是最小的颜色数,所以从头开始遍历, 遇到可以涂的就跳出,同时  颜色的总数我用sum 来标记, 用一个color 来标记一下涂哪个颜色,要比较一下, sum 和color 的大小, 最后的结果为sum, 就是所求值。

在做这道题的时候,就是注意该初始化的地方要初始化, 要不然就会出错,好了,就这些,  代码附上:


#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>
#include <string>
using namespace std;
int co[50][100];
char s[30];

int main(){
	
	int n, i, j;
	while(1){
		scanf("%d", &n);
		if(n == 0)
			break;
		int sum = 0;
		memset(co, 0, sizeof(co));
		
		while(n--){
			int color = 0;
			scanf("%s", &s);
			int len = strlen(s);
			for(i = 1; ; ++i){
				if(co[s[0] - 65][i] == 0){
					color = i;
					break;
				}
			}
			sum = max(sum, color);
			for(i = 2; i < len; ++i)
				co[s[i] - 65][color] = 1;			
		}
		if(sum == 1)
			cout << "1 channel needed." << endl;
		else 
		cout << sum << " channels needed." << endl;
	}
	return 0;
} 

                               

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值