Power Strings

链接 http://poj.org/problem?id=2406

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&
注意s数组的初始化,next【】数组的求法比较简单;
主要是分析next数组求出后的三步;
next数组的含义是这样的,举个例子:
比如:ababababab,初始的时候j=-1,i=0,next[0]=-1;设置i的主要用途是判断串的长度是否到头;

next数组记录的是字符串匹配过程中失配的情况下最多可以向前跳几个字符,next数组也描述子串的匹配程度,next的值越大,子串的匹配程度越高。匹配的速度也越快。(跳的字符多嘛!)next也可以是指前i个字符串对称程度。


#include<stdio.h>

#include<iostream>
#include<cstring>
using namespace std;
char s[1000050];
int next[1000050];
int main()
{
int i,j,k,m,n;
memset(s,'\0',sizeof(s));
while(scanf("%s",s)!=EOF)
{
if(s[0]=='.')
     break;
     int len;
len=strlen(s);
i=0;
j=-1;
next[0]=-1;
while(i<len)
{
if(j==-1||s[i]==s[j])
{
i++;
j++;
next[i]=j;
}
else
{
j=next[j];
}
}
int t=i-next[i];
if(t==0)
      k=i;
        else if(i%t==0)
              k=i/t;
                else
                      k=1;
printf("%d\n",k);
memset(s,'\0',sizeof(s));

return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值