Marriage is Stable

http://acm.hdu.edu.cn/showproblem.php?pid=1522

Problem Description
Albert, Brad, Chuck are happy bachelors who are in love with Laura, Marcy, Nancy. They all have three choices. But in fact, they do have some preference in mind. Say Albert, he likes Laura best, but that doesn't necesarily mean Laura likes him. Laura likes Chuck more than Albert. So if Albert can't marry Laura, he thinks Nancy a sensible choice. For Albert, he orders the girls Laura > Nancy > Marcy.

For the boys:

Albert: Laura > Nancy > Marcy
Brad: Marcy > Nancy > Laura
Chuck: Laura > Marcy > Nancy

For the girls:

Laura: Chuck > Albert > Brad
Marcy: Albert > Chuck > Brad
Nancy: Brad > Albert > Chuck

But if they were matched randomly, such as

Albert <-> Laura
Brad <-> Marcy
Chuck <-> Nancy

they would soon discover it's not a nice solution. For Laura, she likes Chuck instead of Albert. And what's more, Chuck likes Laura better than Nancy. So Laura and Chuck are likely to come together, leaving poor Albert and Nancy.

Now it's your turn to find a stable marriage. A stable marriage means for any boy G and girl M, with their choice m[G] and m[M], it will not happen that rank(G, M) < rank(G, m[G])and rank(M, G) < rank(M, m[M]).
 

Input
Each case starts with an integer n (1 <= n <= 500), the number of matches to make.

The following n lines contain n + 1 names each, the first being name of the boy, and rest being the rank of the girls.

The following n lines are the same information for the girls.

Process to the end of file.
 

Output
If there is a stable marriage, print n lines with two names on each line. You can choose any one if there are multiple solution. Print "Impossible" otherwise.

Print a blank line after each test.
 

Sample Input
  
  
3 Albert Laura Nancy Marcy Brad Marcy Nancy Laura Chuck Laura Marcy Nancy Laura Chuck Albert Brad Marcy Albert Chuck Brad Nancy Brad Albert Chuck
 

Sample Output
  
  
Albert Nancy Brad Marcy Chuck Laura
http://acm.hdu.edu.cn/showproblem.php?pid=1522

&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&&
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<map>
using namespace std;
#define NN 600
int mm[NN][NN],gg[NN][NN],p[NN];
int gg_match[NN],mm_match[NN];//gg_match[i]=j;表示第i个gg喜欢第j个mm;
string ss[NN*2],str;
map<string,int>mp_mm,mp_gg;
int main()
{
	int i,j,k,m,n,cnt,a,b;
	while(scanf("%d",&n)!=EOF)
	{
		mp_gg.clear();
		mp_mm.clear();
		cnt=0;
		for(i=1;i<=n;i++)
		{
			cin>>ss[i];
			mp_gg[ss[i]]=i;
			for(j=1;j<=n;j++)
			{
				cin>>str;
				if(mp_mm[str]==0)
				{
					mp_mm[str]=++cnt;
					ss[n+cnt]=str;	
				}
				gg[i][j]=mp_mm[str];
			}
		}
		for(i=1;i<=n;i++)
		{
			cin>>str;
			a=mp_mm[str];
			for(j=1;j<=n;j++)
			{
				cin>>str;
				b=mp_gg[str];
				mm[a][b]=j;
			}
		}
		int flag=1;
		for(i=1;i<=n;i++)
		{
			p[i]=1;
			mm_match[i]=gg_match[i]=-1;
		}
		while(flag)
		{
			flag=0;
			for(i=1;i<=n;i++)
			{
				if(gg_match[i]==-1&&p[i]<=n)
				{
					a=gg[i][p[i]++];
					if(mm_match[a]==-1)
					{
						mm_match[a]=i;
						gg_match[i]=a;
					}
					else if(mm[a][i]<mm[a][mm_match[a]])
					{
						gg_match[i]=a;
						gg_match[mm_match[a]]=-1;
						mm_match[a]=i;
					}
					flag=1;
				}
			}
		};
		for(i=1;i<=n;i++)
		{
			j=gg_match[i];
			//printf("%d\n",j);
			cout<<ss[i]<<" "<<ss[j+n]<<endl;
		}
		cout<<"\n";
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值