POJ 3667

Hotel
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 9671 Accepted: 4145

Description

The cows are journeying north to Thunder Bay in Canada to gain cultural enrichment and enjoy a vacation on the sunny shores of Lake Superior. Bessie, ever the competent travel agent, has named the Bullmoose Hotel on famed Cumberland Street as their vacation residence. This immense hotel has N (1 ≤ N ≤ 50,000) rooms all located on the same side of an extremely long hallway (all the better to see the lake, of course).

The cows and other visitors arrive in groups of size Di (1 ≤ Di ≤ N) and approach the front desk to check in. Each group i requests a set of Di contiguous rooms from Canmuu, the moose staffing the counter. He assigns them some set of consecutive room numbers r..r+Di-1 if they are available or, if no contiguous set of rooms is available, politely suggests alternate lodging. Canmuu always chooses the value of r to be the smallest possible.

Visitors also depart the hotel from groups of contiguous rooms. Checkout i has the parameters Xi and Di which specify the vacating of rooms Xi ..Xi +Di-1 (1 ≤ Xi ≤ N-Di+1). Some (or all) of those rooms might be empty before the checkout.

Your job is to assist Canmuu by processing M (1 ≤ M < 50,000) checkin/checkout requests. The hotel is initially unoccupied.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Line i+1 contains request expressed as one of two possible formats: (a) Two space separated integers representing a check-in request: 1 and D(b) Three space-separated integers representing a check-out: 2, Xi, and Di

Output

* Lines 1.....: For each check-in request, output a single line with a single integer r, the first room in the contiguous sequence of rooms to be occupied. If the request cannot be satisfied, output 0.

Sample Input

10 6
1 3
1 3
1 3
1 3
2 5 5
1 6

Sample Output

1
4
7
0
5

Source

一道经典的线段树练习,区间合并
题意:1 a:    询问是不是有连续长度为a的空房间,有的话住进最左边
2 a b:     将[a,a+b-1]的房间清空
思路:记录区间中最长的空房间

#include <cstdio>
#include <cmath>
#include <algorithm>
#include <iostream>
#include <cstring>
#include <map>
#include <string>
#include <stack>
#include <cctype>
#include <vector>
#include <queue>
#include <set>
#include <utility>

using namespace std;
//#define Online_Judge
#define outstars cout << "***********************" << endl;
#define clr(a,b) memset(a,b,sizeof(a))
#define lson l , mid  , rt << 1
#define rson mid + 1 , r , rt << 1 | 1

#define mk make_pair
#define FOR(i , x , n) for(int i = (x) ; i < (n) ; i++)
#define FORR(i , x , n) for(int i = (x) ; i <= (n) ; i++)
#define REP(i , x , n) for(int i = (x) ; i > (n) ; i--)
#define REPP(i ,x , n) for(int i = (x) ; i >= (n) ; i--)
const int MAXN = 50000 + 500;
const long long LLMAX = 0x7fffffffffffffffLL;
const long long LLMIN = 0x8000000000000000LL;
const int INF = 0x7fffffff;
const int IMIN = 0x80000000;
#define eps 1e-8
#define mod 1000000007
typedef long long LL;
const double PI = acos(-1.0);
typedef double D;
typedef pair<int , int> pi;
///#pragma comment(linker, "/STACK:102400000,102400000")
int lsum[MAXN <<2] , rsum[MAXN << 2], sum[MAXN << 2] , cover[MAXN << 2];
void pushup(int rt ,int len)
{
    lsum[rt] = lsum[rt << 1];
    rsum[rt] = rsum[rt << 1 | 1];
    if(lsum[rt] == len - (len >> 1))lsum[rt] += lsum[rt << 1 | 1];
    if(rsum[rt] == len >> 1)rsum[rt] += rsum[rt << 1];
    sum[rt] = max(lsum[rt << 1 | 1] + rsum[rt << 1] , max(sum[rt << 1] , sum[rt << 1 | 1]));
}
void pushdown(int rt , int len)
{
    if(cover[rt] != -1)
    {
        cover[rt << 1] = cover[rt << 1| 1] = cover[rt];
        sum[rt << 1] = lsum[rt << 1] = rsum[rt << 1] = cover[rt] == 1? 0:len - (len >> 1);
        sum[rt << 1 | 1] = lsum[rt << 1 | 1] = rsum[rt << 1 | 1] = cover[rt] == 1? 0:(len >> 1);
        cover[rt] = -1;
    }
}
void build(int l , int r, int rt)
{
    sum[rt] = lsum[rt] = rsum[rt] = r - l + 1;
    cover[rt] = -1;
    if(l == r)return ;
    int mid = (l + r) >> 1;
    build(lson) , build(rson);
}
void update(int L ,int R , int c , int l , int r ,int rt)
{
    if(L <= l&& r <= R)
    {
        sum[rt] = lsum[rt] = rsum[rt] = c ? 0 : r - l + 1;
        cover[rt] = c;
        return;
    }
    pushdown(rt , r - l + 1);
    int mid = (l + r) >> 1;
    if(L <= mid)update(L ,R , c , lson);
    if(mid < R)update(L ,R , c , rson);
    pushup(rt , r - l + 1);
}
int query(int w , int l , int r , int rt)
{
    if(l == r)return l;
    pushdown(rt , r - l + 1);
    int mid = (l + r) >> 1;
    if(sum[rt << 1] >= w)return query(w , lson);
    else if(rsum[rt << 1] + lsum[rt << 1 | 1] >= w)return mid - rsum[rt << 1] + 1;
    else return query(w , rson);
}
int main()
{
    //ios::sync_with_stdio(false);
    #ifdef Online_Judge
        freopen("in.txt","r",stdin);
        freopen("out.txt","w",stdout);
    #endif // Online_Judge
    int n , m  , a , b , op;
    while(~scanf("%d%d" , &n , &m))
    {
        build(1 , n , 1);
        while(m--)
        {
            scanf("%d" , &op);
            if(op == 1)
            {
                scanf("%d", &a);
                if(sum[1] < a)printf("0\n");
                else
                {
                    int p = query(a ,1 , n , 1);
                    printf("%d\n" , p);
                    update(p , p + a - 1 , 1 , 1 , n , 1);
                }
            }
            else
            {
                scanf("%d%d" ,&a , &b);
                update(a , b + a - 1 , 0 , 1 , n , 1);
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值