Legal or Not

Problem Description
 
       ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?

       We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not.

Please note that the "master and prentice" relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.
 

Input
 
       The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y's master and y is x's prentice. The input is terminated by N = 0. TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.
 

Output
 
     For each test case, print in one line the judgement of the messy relationship. If it is legal, output "YES", otherwise "NO".
 

Sample Input
 
  
  
3 2 0 1 1 2 2 2 0 1 1 0 0 0
 

Sample Output
 
  
  
YES NO
 
 
 
         在一个群里面,大家互相请教问题,比如A请教B,我们就把B叫做师傅,把A叫做徒弟,这样会产生很多“师傅——徒弟”的关系,一个徒弟可以有很多的师傅,一个师傅也可以有很多徒弟,这是合法的,但是不能出现A是B的师傅而且B是A的师傅,或者A是B的徒弟而且B是A的徒弟,或者在一个更大的关系环里面出现这种情况。很明显题目的意思就是,判断一个给定的有向图中是否存在环。了解了这些,解题方法就非常简单了,那就是直接进行拓扑排序即可,统计拓扑排序完成之时能记录的度为0的节点的个数,若个数等于节点个数则说明无环,否则是有环的。
 
 
 
#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;
int map[200][200];
int indegree[200];
int n,m;
int topo()
{
	priority_queue<int,vector<int>,greater<int> >q;
	int i,j,k=0,top;
	for(i=0;i<n;i++)<span style="color:#ff0000;">//要看清题目,编号是从0开始的,错在这里啦 !! 
</span>	{
		if(indegree[i]==0)
		  q.push(i);
	}
	while(!q.empty())
	{
		
		top=q.top();
		q.pop();
		indegree[top]--;
		k++;
		for(j=0;j<n;j++) <span style="color:#cc0000;">//编号是从0开始的!! 
</span>		{
			if(map[top][j]==1)
			  {
			  	indegree[j]--;
			  	if(indegree[j]==0)
			  	   q.push(j);
			  }
		}
	}
	if(k==n)
	  return 1;
	  else
	    return 0;

}
int main()
{
	while(scanf("%d%d",&n,&m)!=EOF&&n)
	{
		memset(map,0,sizeof(map));
		memset(indegree,0,sizeof(indegree));
		int i,j,a,b;
		for(i=1;i<=m;i++)
		{
			scanf("%d%d",&a,&b);
			if(map[a][b]==0)
			  {
			  	map[a][b]=1;
			  	indegree[b]++;
			  }
		}
		if(topo())
		  printf("YES\n");
		else
		  printf("NO\n");
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值