1049. Counting Ones (30)-PAT

1049. Counting Ones (30)

时间限制
10 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The task is simple: given any positive integer N, you are supposed to count the total number of 1's in the decimal form of the integers from 1 to N. For example, given N being 12, there are five 1's in 1, 10, 11, and 12.

Input Specification:

Each input file contains one test case which gives the positive N (<=230).

Output Specification:

For each test case, print the number of 1's in one line.

Sample Input:
12
Sample Output:
5
推荐指数:※※
来源:http://pat.zju.edu.cn/contests/pat-a-practise/1049
这道题在剑指offer上面也有,不错个人觉得http://blog.csdn.net/sunbaigui/article/details/8672335分别计算每一位1更为高效和好理解。
#include <iostream>
using namespace std;
int Count(int n)
{
	int sum,now,left,right;
	int base;
	base=1;
	sum=0;
	while(n/base!=0){
		now=(n/base)%10;/*the number of now*/
		left=n/(base*10);/*the number of left*/
		right=n%base;/*the number of right*/
		if(now==0){
			sum+=left*base;
		}
		else if(now==1)
		{
			sum+=left*base+right+1;
		}
		else
		{
			sum+=(left+1)*base;
		}
		base=base*10;
	}
	return sum;
}
int main()
{
	int n;
	cin>>n;
	cout<<Count(n)<<endl;
	return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值