Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 29178 | Accepted: 11690 |
Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:
Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…
Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.
So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.
Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:
- One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
- One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.
Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
Sample Input
3 BAPC BAPC AZA AZAZAZA VERDI AVERDXIVYERDIAN
Sample Output
1 3 0
Source
C风格的输入节省时间
AC代码:
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#define maxw 10000+1
#define maxt 1000000+1
using namespace std;
char word[maxw];
char text[maxt];
int suffix[maxw];
int lenw,lent;
int kmp(){
int cns=0;
int posw=0,post=0;
///cout<<"lent: "<<lent<<'\12';
while(post<lent){
if(word[posw]==text[post]){
posw++;
post++;
}
else if(posw>=0){
posw=suffix[posw];
}
else {
post++;
posw=0;
}
if(posw==lenw){
cns++;
posw=suffix[posw];
}
}
return cns;
}
int main(){
int loop;
scanf("%d",&loop);
while(loop--){
scanf("%s%s",word,text);
lent=strlen(text);
lenw=strlen(word);
int pos=0,i,j;
suffix[0]=-1;
suffix[1]=0;
for( i=2;i<=lenw;++i){
while(pos>=0&&word[pos]!=word[i-1])
pos=suffix[pos];
suffix[i]=++pos;
}
///for(j=0;j<i;++j)cout<<"suffix["<<j<<"]: "<<suffix[j]<<'\12';
printf("%d\n",kmp());
}
return 0;
}