POJ 2479 Maximum sum && 2593 Max Sequence (dp)买一送一

Max Sequence
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 16511 Accepted: 6921

Description

Give you N integers a1, a2 ... aN (|ai| <=1000, 1 <= i <= N). 

You should output S. 

Input

The input will consist of several test cases. For each test case, one integer N (2 <= N <= 100000) is given in the first line. Second line contains N integers. The input is terminated by a single line with N = 0.

Output

For each test of the input, print a line containing S.

Sample Input

5
-5 9 -5 11 20
0

Sample Output

40

Source

ACcode:
#include <cmath>
#include <cstdio>
#include <iostream>
#define maxn  100000+5
using namespace std;
int a[maxn],dp[maxn],pd[maxn],sum;
int main(){
    int loop,n;
    while(scanf("%d",&n)&&n){
        scanf("%d",&a[1]);
        dp[0]=pd[n+1]=-maxn;
        dp[1]=a[1];
        for(int i=2;i<=n;++i){
            scanf("%d",&a[i]);
            dp[i]=max(dp[i-1]+a[i],a[i]);
        }
        pd[n]=a[n];
        for(int i=n-1;i>0;--i){
            pd[i]=max(pd[i+1]+a[i],a[i]);
        }
        for(int i=1,j=n-1;i<=n;++i,--j){
            dp[i]=max(dp[i],dp[i-1]);
            pd[i]=max(pd[i],pd[i+1]);
           // printf("dp[%d]==%d  pd[%d]==%d\n",i,dp[i],i,pd[i]);
        }
        sum=dp[1]+pd[2];
        for(int i=2;i<=n;++i)
            sum=max(sum,dp[i]+pd[i+1]);
        printf("%d\n",sum);
    }
    return 0;
}

Maximum sum
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 36441 Accepted: 11309

Description

Given a set of n integers: A={a1, a2,..., an}, we define a function d(A) as below:
Your task is to calculate d(A).

Input

The input consists of T(<=30) test cases. The number of test cases (T) is given in the first line of the input. 
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, ..., an. (|ai| <= 10000).There is an empty line after each case.

Output

Print exactly one line for each test case. The line should contain the integer d(A).

Sample Input

1

10
1 -1 2 2 3 -3 4 -4 5 -5

Sample Output

13

Hint

In the sample, we choose {2,2,3,-3,4} and {5}, then we can get the answer. 

Huge input,scanf is recommended.

Source

POJ Contest,Author:Mathematica@ZSU
ACcode:
#include <cmath>
#include <cstdio>
#include <iostream>
#define maxn 50000+5
using namespace std;
int a[maxn],dp[maxn],pd[maxn],sum;
int main(){
    int loop,n;
    scanf("%d",&loop);
    while(loop--){
        scanf("%d",&n);
        scanf("%d",&a[1]);
        dp[0]=pd[n+1]=-maxn;
        dp[1]=a[1];
        for(int i=2;i<=n;++i){
            scanf("%d",&a[i]);
            dp[i]=max(dp[i-1]+a[i],a[i]);
        }
        pd[n]=a[n];
        for(int i=n-1;i>0;--i){
            pd[i]=max(pd[i+1]+a[i],a[i]);
        }
        for(int i=1,j=n-1;i<=n;++i,--j){
            dp[i]=max(dp[i],dp[i-1]);
            pd[i]=max(pd[i],pd[i+1]);
           // printf("dp[%d]==%d  pd[%d]==%d\n",i,dp[i],i,pd[i]);
        }
        sum=dp[1]+pd[2];
        for(int i=2;i<=n;++i)
            sum=max(sum,dp[i]+pd[i+1]);
        printf("%d\n",sum);
    }
    return 0;
}


  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值