Y2K Accounting Bug(二进制+枚举)

E - Y2K Accounting Bug
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Appoint description: 

Description

Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc. 
All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite. 

Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.

Input

Input is a sequence of lines, each containing two positive integers s and d.

Output

For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.

Sample Input

59 237
375 743
200000 849694
2500000 8000000

Sample Output

116
28
300612
Deficit
 
   
题意:
   题意真心看不懂,之后看了题解才知道怎么做。他就是说每个月分别只有盈利与亏损两种情况,而还有个附加条件就是1-5,
2-6,3-7,4-8,5,9,6-10,7-11,8-12,都要是亏损的。求在这种情况下的1-12个月总和是大于零的最大值。
 
   
AC代码:
 
   
#include<iostream>
#include<algorithm>
#include<cstring>
#include<string>
#include<cstdio>
#include<vector>
#include<cmath>
using namespace std;
#define T 5005
#define inf -0x3f3f3f3f
int a[12],b[2],c;
bool jugde()
{
	for(int i=0;i<=7;++i){
		if(b[a[i]]+b[a[i+1]]+b[a[i+2]]+b[a[i+3]]+b[a[i+4]]>=0)
			return false;
	}
	return true;
}
int Sum()
{
	int s=0;
	for(int i=0;i<12;++i)
		s+=b[a[i]];
	return s;
}
void out()
{
	for(int i=11;i>=0;--i)
	printf("%d ",a[i]);
	printf("\n");
}
int main()
{
	/*freopen("input.txt","r",stdin);*/
	int n,m,i,j,k,tmp,sum;
	
	while(~scanf("%d%d",&b[0],&b[1]))
	{
		sum = 0;b[1]=-b[1];
		for(i=0;i<(1<<12);++i){
			c=0;j=i;
			while(c<12){
				a[c++]=j&1;
				j>>=1;
			}
			/*out();*/
			if(jugde()){
				sum=max(sum,Sum());
			}
		}
		if(sum!=0)
		printf("%d\n",sum);
		else
		printf("Deficit\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值