HDU ~ 2923 ~ Einbahnstrasse(floyd+map)

题目网址:HDU-2923-Einbahnstrasse

Einbahnstrasse

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)


Problem Description
Einbahnstra e (German for a one-way street) is a street on which vehicles should only move in one direction. One reason for having one-way streets is to facilitate a smoother flow of traffic through crowded areas. This is useful in city centers, especially old cities like Cairo and Damascus. Careful planning guarantees that you can get to any location starting from any point. Nevertheless, drivers must carefully plan their route in order to avoid prolonging their trip due to one-way streets. Experienced drivers know that there are multiple paths to travel between any two locations. Not only that, there might be multiple roads between the same two locations. Knowing the shortest way between any two locations is a must! This is even more important when driving vehicles that are hard to maneuver (garbage trucks, towing trucks, etc.)

You just started a new job at a car-towing company. The company has a number of towing trucks parked at the company's garage. A tow-truck lifts the front or back wheels of a broken car in order to pull it straight back to the company's garage. You receive calls from various parts of the city about broken cars that need to be towed. The cars have to be towed in the same order as you receive the calls. Your job is to advise the tow-truck drivers regarding the shortest way in order to collect all broken cars back in to the company's garage. At the end of the day, you have to report to the management the total distance traveled by the trucks.

Input
Your program will be tested on one or more test cases. The first line of each test case specifies three numbers (N , C , and R ) separated by one or more spaces. The city has N locations with distinct names, including the company's garage. C is the number of broken cars. R is the number of roads in the city. Note that 0 < N < 100 , 0<=C < 1000 , and R < 10000 . The second line is made of C + 1 words, the first being the location of the company's garage, and the rest being the locations of the broken cars. A location is a word made of 10 letters or less. Letter case is significant. After the second line, there will be exactly R lines, each describing a road. A road is described using one of these three formats:


A -v -> B
A <-v - B
A <-v -> B


A and B are names of two different locations, while v is a positive integer (not exceeding 1000) denoting the length of the road. The first format specifies a one-way street from location A to B , the second specifies a one-way street from B to A , while the last specifies a two-way street between them. A , ``the arrow", and B are separated by one or more spaces. The end of the test cases is specified with a line having three zeros (for N , C , and R .)

The test case in the example below is the same as the one in the figure.


Output
For each test case, print the total distance traveled using the following format:


k . V


Where k is test case number (starting at 1,) is a space, and V is the result.

Sample Input
  
  
4 2 5 NewTroy Midvale Metrodale NewTroy <-20-> Midvale Midvale --50-> Bakerline NewTroy <-5-- Bakerline Metrodale <-30-> NewTroy Metrodale --5-> Bakerline 0 0 0

Sample Output
  
  
1. 80

Source

Recommend
lcy

题意:最短路floyd;先给你N,C,R;N代表总共有几个点,然后C代表你要去的几个地点,R表示有多少条路,路有单向和双向箭头所指方向就是路的方向;第二行先给你一个开始地点加入记为S,然后给你C个地点,问的是你从S到那C个点再回到S点的最短路;

思路:典型的floyd;这题难在输入,存储和提取有效信息;可以采取scanf的格式化输入和map映射(这个我也是刚学的用的不太好,请大家多多指教);

#include <bits/stdc++.h>
using namespace std;
const int INF=0x3f3f3f3f;
int N,C,R,G[105][105];
string S,E[1005];
void floyd()
{
	for(int k=1;k<=N;k++)
	{
		for(int i=1;i<=N;i++)
		{
			for(int j=1;j<=N;j++)
			{
				G[i][j]=min(G[i][j],G[i][k]+G[k][j]);
			}
		}
	}
}
int main()
{
	int k=1;
	while(cin>>N>>C>>R)
	{
		if(N==0&&C==0&&R==0)
		{
			break;
		}
		memset(G,INF,sizeof(G));
		for(int i=0;i<=N;i++)
		{
			G[i][i]=0;
		}
		cin>>S;//输入开始点 
		for(int i=1;i<=C;i++)//要去的几个地点 
		{
			cin>>E[i];
		}
		map<string,int>MAP;//用map映射地点 
		MAP.clear();//清空map 
		int cnt=1,D;
		char a,b,s[1000],e[1000];
		for(int i=0;i<R;i++)
		{
			scanf("%s %c-%d-%c %s",s,&a,&D,&b,e);
			if(!MAP[s])//如果这个地点没出现过,则加入map 
			{
				MAP[s]=cnt;
				cnt++;	
			}
			if(!MAP[e]) 
			{
				MAP[e]=cnt;
				cnt++;	
			}
			if(a=='<')
			{
				if(D<G[MAP[e]][MAP[s]])//防止给你两条A->B路 
				{
					G[MAP[e]][MAP[s]]=D;
				}
			}
			if(b=='>')
			{
				if(D<G[MAP[s]][MAP[e]])
				{
					G[MAP[s]][MAP[e]]=D;
				}
				
			}
		}
		floyd();
		int MIND=0;
		for(int i=1;i<=C;i++)//将这些最短路加和就是答案 
		{
			MIND=MIND+G[MAP[S]][MAP[E[i]]]+G[MAP[E[i]]][MAP[S]];
		}
		cout<<k++<<". "<<MIND<<endl;
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值