老版本出现"-fembed-bitcode"错误解决办法

转载 2015年11月20日 11:17:51

原blog:http://blog.csdn.net/zszeng/article/details/48709365    侵删


错误提示

-fembed-bitcode is not supported on versions of iOS prior to 6.0

这里写图片描述

这时候到build setting里面设置查找”enable_bitcode”, 并把设置改为”NO” 
这里写图片描述

Impact of Xcode build options “Enable bitcode” Yes/No

来自:  
http://stackoverflow.com/questions/31088618/impact-of-xcode-build-options-enable-bitcode-yes-no/32753202#32753202

From the docs

  • can I use the above method without any negative impact and without compromising a future appstore submission?

Bitcode will allow apple to optimise the app without you having to submit another build. But, you can only enable this feature if all frameworks and apps in the app bundle have this feature enabled. Having it helps, but not having it should not have any negative impact.

  • What does the ENABLE_BITCODE actually do, will it be a non-optional requirement in the future?

For iOS apps, bitcode is the default, but optional. If you provide bitcode, all apps and frameworks in the app bundle need to include bitcode. For watchOS apps, bitcode is required.

  • Are there any performance impacts if I enable / disable it?

The App Store and operating system optimize the installation of iOS and watchOS apps by tailoring app delivery to the capabilities of the user’s particular device, with minimal footprint. This optimization, called app thinning, lets you create apps that use the most device features, occupy minimum disk space, and accommodate future updates that can be applied by Apple. Faster downloads and more space for other apps and content provides a better user experience.

There should not be any performance impacts.

Xcode 7中ENABLE_BITCODE错误解决

来自: 
http://anotheren.com/48

最近编译中出现了ENABLE_BITCODE报错的问题,我使用的是Xcode7bate4(7A165t),使用调试的iOS版本是8.4正式版。开始的时候我还以为是iOS8.4与Xcode7有兼容问题,顺便把手机升到了9.0(13A4305g),问题依旧。

认真的Google了一下,发现ENABLE_BITCODE是Xcode的一项新特性,引用一下官方说明: 
https://developer.apple.com/library/prerelease/watchos/documentation/IDEs/Conceptual/AppDistributionGuide/AppThinning/AppThinning.html#//apple_ref/doc/uid/TP40012582-CH35-SW2

也就是对于iOS的应用来说,Bitcode是可选的,但对于新的watchOS而言,它是必须的。很明显,是由于我使用的PLCameraStreamingKit未包含bitcode,导致编译失败。所以,我们需要找Enable Bitcode选项,将默认的Yes改为No即可临时解决这个问题。那什么时候可以彻底根治这个问题呢,只有等到你工程中所有使用的框架均支持Bitcode才行。

Bitcode 导致编译失败 #13829

来自: 
https://github.com/cocos2d/cocos2d-x/issues/13829

主要是模拟器编译不过,真机可以在自己关闭target Enable Bitcode后编译通过

Xcode7正式版 出现”-fembed-bitcode”错误

来自: 
http://support.cocos.com/feedback/detail?msg_id=3908


相关文章推荐

"-fembed-bitcode is not supported on versions of iOS prior to 6.0" 错误

“-fembed-bitcode is not supported on versions of iOS prior to 6.0” 错误今天准备打发布包,Archive的时候,出现了这个错误。经过各...
  • chiyun1
  • chiyun1
  • 2015年09月18日 10:14
  • 3363

-fembed-bitcode is not supported on versions of iOS prior to 6.0

“Xcode 7 ENABLE_BITCODE选项bitcode嵌入应用程序,应用程序扩展,和框架。选项是默认开启的iOS和watchOS项目提交给商店的是强制性的。当启用bitcode为目标,所有对...

-fembed-bitcode is not supported on versions of iOS prior to 6.0

-fembed-bitcode is not supported on versions of iOS prior to 6.0
  • Ydc__
  • Ydc__
  • 2015年10月10日 16:14
  • 6731

Xcode7 出现"-fembed-bitcode"错误的解决办法

错误提示 -fembed-bitcode is not supported on versions of iOS prior to 6.0 这时候到build setting里面设置查找”enab...
  • zszeng
  • zszeng
  • 2015年09月24日 12:15
  • 6278

Bitcode真机测试要修改为 NO

You must rebuild it with bitcode enabled(Xcode setting ENABLE_BITCODE), obtain an updated library fr...

IOS开发之类的声明与实现

类的声明和实现 1. @interface和@implementation的区别 @interface就好像暴露在外面的时钟表面 @implementation就好像隐藏在时钟内部的构造实现 ...

IOS7 tabBarItem 自定义图片的设置

IOS7之前:

Xcode7正式版 出现”-fembed-bitcode”错误

错误提示 -fembed-bitcode is not supported on versions of iOS prior to 6.0 这时候到build settin...

关于 “does not contain bitcode.”的错误解决办法

Xcode7运行项目时出现了如下的错误:does not contain bitcode. You must rebuild it with bitcode enabled (Xcode settin...

ubuntu14.04 mysql升级到5.7版本出现GPG error错误解决办法

先说一下升级的方法: 首先备份数据,下面是具体安装步骤: 1、下载mysql-apt的配置包,并安装 wget https://dev.mysql.com/get/mysql-apt-config_0...
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:老版本出现"-fembed-bitcode"错误解决办法
举报原因:
原因补充:

(最多只允许输入30个字)