POJ:3620 Avoid The Lakes(深搜DFS)

12 篇文章 0 订阅
Avoid The Lakes
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7949 Accepted: 4180

Description

Farmer John's farm was flooded in the most recent storm, a fact only aggravated by the information that his cows are deathly afraid of water. His insurance agency will only repay him, however, an amount depending on the size of the largest "lake" on his farm.

The farm is represented as a rectangular grid with N (1 ≤ N ≤ 100) rows and M (1 ≤ M ≤ 100) columns. Each cell in the grid is either dry or submerged, and exactly K (1 ≤ K ≤ N × M) of the cells are submerged. As one would expect, a lake has a central cell to which other cells connect by sharing a long edge (not a corner). Any cell that shares a long edge with the central cell or shares a long edge with any connected cell becomes a connected cell and is part of the lake.

Input

* Line 1: Three space-separated integers: NM, and K
* Lines 2..K+1: Line i+1 describes one submerged location with two space separated integers that are its row and column: R and C

Output

* Line 1: The number of cells that the largest lake contains. 

Sample Input

3 4 5
3 2
2 2
3 1
2 3
1 1

Sample Output

4

Source



题目大意:给你一块n*m的土地,上面有k块水坑,然后k行水坑的坐标,相邻前后左右的水坑能混合成一个大水坑,最大水坑有多大。
解题思路:深搜,将水坑的坐标标记,然后扫一遍图,如果扫到水坑的话进入搜索,将坑填平,每进入一次搜索,则填一次(大)坑,然后更新max。
代码如下:
#include <cstdio>
#include <cstring>
int n,m,k,tmpn,tmpm,max,cnt;
int map[110][110];
void dfs(int hang,int lie)
{
	if(hang>=1&&lie>=1&&hang<=n&&lie<=m&&map[hang][lie]==1)//不越界,且是坑 
	{
		cnt++;
		map[hang][lie]=0;//将坑填平 
	}
	else
	{
		return ;
	}
	dfs(hang+1,lie);//向周边搜索 
	dfs(hang-1,lie);
	dfs(hang,lie+1);
	dfs(hang,lie-1);
}
int main()
{
	scanf("%d%d%d",&n,&m,&k);
	memset(map,0,sizeof(map));
	for(int i=0;i<k;i++)
	{
		scanf("%d%d",&tmpn,&tmpm);
		map[tmpn][tmpm]=1;
	}
	max=0;
	for(int i=1;i<=n;i++)
	{
		for(int j=1;j<=m;j++)
		{
			if(map[i][j]==1)
			{
				cnt=0;
				dfs(i,j);
				if(cnt>max)//更新max 
				{
					max=cnt;
				}
			}
		}
	}
	printf("%d\n",max);
	return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值