HDOJ 1009 FatMouse' Trade

FatMouse' Trade

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 1   Accepted Submission(s) : 1
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

Sample Output

13.333
31.500
 
 
贪心算法基本题,题目很简单,但是英语渣渣的我,实在是看不懂题目难过难过
 
 
代码如下:
 
 
</pre><pre name="code" class="html">
<pre name="code" class="html">#include<stdio.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;


struct food
{
	int j;//房间内可兑换的JavaBean的数量 
	int f;//所需的cat food的数量 
	double q;//j与i的比值 
}a[1100];


double cmp(food a,food b)
{
	return a.q>b.q;
}


int main()
{
	int m,n,i;
	double sum;
	while(scanf("%d%d",&m,&n)&&(m!=-1)||(n!=-1))
	{
		for(i=0;i<n;i++)
		{
			scanf("%d%d",&a[i].j,&a[i].f);
			a[i].q=a[i].j*1.0/a[i].f;//注意:两个int型数相除结果还是int型; 
		}
		sort(a,a+n,cmp);
		sum=0.0;
		for(i=0;i<n;i++)
		{
			if(m>=a[i].f)
			{
				sum=sum+a[i].j;
				m=m-a[i].f;
			}
			else if(m<a[i].f&&m>=0)//不能用if,两种情况,二选一 
			{
				sum=sum+(m*a[i].q);
				break;
			}
		}
		printf("%.3lf\n",sum);
	}
	return 0;
}


 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值