HDOJ 1250 Hat's Fibonacci(大数,错了11次!!)

Hat's Fibonacci

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9103    Accepted Submission(s): 2953


Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.
 

Input
Each line will contain an integers. Process to end of file.
 

Output
For each case, output the result in a line.
 

Sample Input
  
  
100
 

Sample Output
  
  
4203968145672990846840663646 Note: No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.
 


 

神题,各种超RT,各种运行超限。。。

 

题目没有直接给出n的最大值,只给出了数列中最大数长度不超过2005,据大牛测试n为7060时,长度为2012。这样就知道数组长度

至少为7060。然而并没有什么乱用,常规做法还是会超限。 这里可以用数组的每一个纵向下标储存4位数解决超限问题。

 

上代码:

 

#include<cstdio>
#define num 8000
#define max 510
int a[num][max];

void fib()
{
	int i,j,c,s;
	a[1][max-1]=a[2][max-1]=a[3][max-1]=a[4][max-1]=1;
	for(i=5;i<num;i++)
	{
		c=0;
		for(j=max-1;j>=0;j--)
		{
			s=a[i][j]+a[i-1][j]+a[i-2][j]+a[i-3][j]+a[i-4][j]+c;
			a[i][j]=s%10000;
			c=s/10000;
		}
	}
}

int main()
{
	fib();
	int n,i;
	while(scanf("%d",&n)!=EOF)
	{
		for(i=0;i<max;i++)
		   if(a[n][i]!=0)
		      break;
		printf("%d",a[n][i]);
		i++;
		for(;i<max;i++)
		   printf("%04d",a[n][i]);
		printf("\n");
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值