HDOJ 1503 Advanced Fruits(LCS)

Advanced Fruits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2036    Accepted Submission(s): 1040
Special Judge


Problem Description
The company "21st Century Fruits" has specialized in creating new sorts of fruits by transferring genes from one fruit into the genome of another one. Most times this method doesn't work, but sometimes, in very rare cases, a new fruit emerges that tastes like a mixture between both of them.
A big topic of discussion inside the company is "How should the new creations be called?" A mixture between an apple and a pear could be called an apple-pear, of course, but this doesn't sound very interesting. The boss finally decides to use the shortest string that contains both names of the original fruits as sub-strings as the new name. For instance, "applear" contains "apple" and "pear" (APPLEar and apPlEAR), and there is no shorter string that has the same property.

A combination of a cranberry and a boysenberry would therefore be called a "boysecranberry" or a "craboysenberry", for example.

Your job is to write a program that computes such a shortest name for a combination of two given fruits. Your algorithm should be efficient, otherwise it is unlikely that it will execute in the alloted time for long fruit names.
 

Input
Each line of the input contains two strings that represent the names of the fruits that should be combined. All names have a maximum length of 100 and only consist of alphabetic characters.

Input is terminated by end of file.
 

Output
For each test case, output the shortest name of the resulting fruit on one line. If more than one shortest name is possible, any one is acceptable.
 

Sample Input
  
  
apple peach ananas banana pear peach
 

Sample Output
  
  
appleach bananas pearch
 
题意:结合两个字符串,他们的公共子序列只输出一次。
 
题解:利用LCS算法标记字符,分别标记两串的公共字符,A串独有的字符,B串独有的字符。再利用递归函数才大到小遍历,从小到大回溯输出,既可以得到题意中要求的杂交串。
 
注意:样例数据的输出不一定要和样例输出一致,是满足题目要求的任意杂交串。
 
代码如下:
 
<span style="font-size:12px;">#include<cstdio>
#include<cstring>
char a[110],b[110];
int dp[110][110],lena,lenb,mark[110][110];

void LCS()
{
	int i,j;
	memset(dp,0,sizeof(dp));
	for(i=0;i<lena;++i)
	   mark[i][0]=1;
	for(i=0;i<lenb;++i)
	   mark[0][i]=-1;
	for(i=1;i<=lena;++i)
	{
		for(j=1;j<=lenb;++j)
		{
			if(a[i-1]==b[j-1])
			{
				dp[i][j]=dp[i-1][j-1]+1;
				mark[i][j]=0;
			}
			else if(dp[i-1][j]>=dp[i][j-1])
			{
				dp[i][j]=dp[i-1][j];
				mark[i][j]=1;
			}
			else
			{
				dp[i][j]=dp[i][j-1];
				mark[i][j]=-1;
			}
		}
	}
}

void out(int x,int y)
{
	if(!x&&!y)
	   return ;
	else if(mark[x][y]==0)
	{
		out(x-1,y-1);
		printf("%c",a[x-1]);
	}
	else if(mark[x][y]==1)
	{
		out(x-1,y);
		printf("%c",a[x-1]);
	}
	else if(mark[x][y]==-1)
	{
		out(x,y-1);
		printf("%c",b[y-1]);
	}
}

int main()
{
	while(scanf("%s%s",&a,&b)!=EOF)
	{
		lena=strlen(a);
		lenb=strlen(b);
		LCS();
		out(lena,lenb);
		printf("\n");//注意换行 
	}
	return 0;
}</span>

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值