POJ 3292 Semi-prime H-numbers(艾氏筛法变形)

Semi-prime H-numbers

Time Limit: 1000MS


Memory Limit: 65536K

Total Submissions: 8323


Accepted: 3616

Description

This problem is based on an exercise of David Hilbert, who pedagogically suggested that one study the theory of 4n+1 numbers. Here, we do only a bit of that.

An H-number is a positive number which is one more than a multiple of four: 1, 5, 9, 13, 17, 21,... are the H-numbers. For this problem we pretend that these are the only numbers. The H-numbers are closed under multiplication.

As with regular integers, we partition the H-numbers into units, H-primes, and H-composites. 1 is the only unit. An H-number h is H-prime if it is not the unit, and is the product of two H-numbers in only one way: 1 × h. The rest of the numbers are H-composite.

For examples, the first few H-composites are: 5 × 5 = 25, 5 × 9 = 45, 5 × 13 = 65, 9 × 9 = 81, 5 × 17 = 85.

Your task is to count the number of H-semi-primes. An H-semi-prime is an H-number which is the product of exactly two H-primes. The two H-primes may be equal or different. In the example above, all five numbers are H-semi-primes. 125 = 5 × 5 × 5 is not an H-semi-prime, because it's the product of three H-primes.

Input

Each line of input contains an H-number ≤ 1,000,001. The last line of input contains 0 and this line should not be processed.

Output

For each inputted H-number h, print a line stating h and the number of H-semi-primes between 1 and h inclusive, separated by one space in the format shown in the sample.

Sample Input

21 
85
789
0

Sample Output

21 0
85 5
789 62


题意:题目看得好吃力,题意说详细点。规定被4整除余1的数叫做H-number。H-number分为三类:

①:H-prime为H-number中的素数,在H-number中这种数只能1和自身整除,不能被其他的H-number整除。但是可以被非H-number的数整除。 例如21, 首先是一个H-number,它能被1,3,7,21整除,因为3,7不是H-number,所以21是H-prime。

②:H-semi-prime由两个H-prime相乘得到的。

③:剩下的数为H-composite。


题解:艾氏筛法的变形,先筛选出H-primes,再记录下H-semi-primes,最后记录下从1到h的H-semi-primes的个数就行了。


代码如下:


#include<cstdio>
#define maxn 1000010
int H_primes[maxn],H_semi_primes[maxn];
int num_primes[maxn];

void table()//弱弱地打表,有菊苣打表0MS,屌炸了 
{
	int i,j;
	H_primes[1]=0; 
	//*********艾氏筛法******** 
	for(i=5;i<maxn;i+=4)
	{
		if(H_primes[i])
			continue;
		for(j=i*5;j<maxn;j+=i*4)
			H_primes[j]=1;
	}
	//************************* 
	int cnt;
	for(i=5;i<maxn;i+=4)//确定H-semi-primes 
	{
		for(j=5;j<maxn;j+=4)
		{
			if(i*j>maxn)//注意这里优化 
				break;
			if(!H_primes[i]&&!H_primes[j])
				H_semi_primes[i*j]=1;
		}
	}
	cnt=0;
	for(i=5;i<maxn;++i)//统计从0到i的H-semi-primes的个数 
	{
		if(H_semi_primes[i])
			num_primes[i]=++cnt;
		else
			num_primes[i]=cnt;
	}
}

int main()
{
	int n;
	table();
	while(scanf("%d",&n)&&n)
	{
		printf("%d %d\n",n,num_primes[n]);
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值