POJ 2352 HDOJ 1541 Stars(树状数组)

Stars
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 39895 Accepted: 17312

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

 
 
5
1 1
5 1
3 3
7 1
5 5

Sample Output

 
 
1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.


题意:在一个坐标的一象限(包括点(0,0))中有n个点,每个点都有自己的等级,点(x,y)等级为它左下方点的个数,包括正左方和正下方。 输出等级0到等级n-1各有多少个点。

题解:题目数据中点按照y轴升序给出。而对于点(x,y)的左下方点的个数就是xi<=x,yi<=y的点的个数。在题中对于任意 xi 只用求得 xj<=xi,(j<=i)的 j 的个数。 最后放入level数组中统计每个等级的点的个数。

暴力法hdoj可以过,poj TLE

代码如下:

#include<cstdio>
#include<cstring>
#define maxn 32000+10
int bit[maxn];
int level[maxn/2];

int sum(int x)
{
	int ans=0;
	while(x>0)
	{
		ans+=bit[x];
		x-=(x&-x);
	}
	return ans;
}

void add(int x)
{
	while(x<=maxn)
	{
		bit[x]+=1;
		x+=(x&-x);
	}
}

int main()
{
	int n,i,x,y;
	while(scanf("%d",&n)!=EOF)
	{
		memset(bit,0,sizeof(bit));
		memset(level,0,sizeof(level));
		for(i=0;i<n;++i)
		{
			scanf("%d%d",&x,&y);
			x++;//这里是允许x坐标为0的,所以将每个点横坐标都加1 
			level[sum(x)]++;
			add(x);
		}
		for(i=0;i<n;++i)
			printf("%d\n",level[i]);
	}
	return 0;
} 




Python网络爬虫与推荐算法新闻推荐平台:网络爬虫:通过Python实现新浪新闻的爬取,可爬取新闻页面上的标题、文本、图片、视频链接(保留排版) 推荐算法:权重衰减+标签推荐+区域推荐+热点推荐.zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值