POJ 1001 Exponentiation解题报告

Exponentiation
Time Limit: 500MS Memory Limit: 10000K
Total Submissions: 127985 Accepted: 31266

Description

Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. 

This problem requires that you write a program to compute the exact value of R n where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.

Input

The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

Output

The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.

Sample Input

95.123 12
0.4321 20
5.1234 15
6.7592  9
98.999 10
1.0100 12

Sample Output

548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201
解题思路:解题的关键是大整数的乘法以及0和小数点的处理。
/*
*project:1001
*version:AC+大整数乘法
*author:骨灰在飞扬
*Memory:236K
*Time:16MS
*note:
*date:2014/2/10
*/
#include <iostream>
#include <string>
#include <algorithm>
#include <fstream>
using namespace std;
const int MAX_LEN = 1000;
int ia[MAX_LEN];

string subF(string str1, string str2)
{    
     int i,j;
     string result;
     memset(ia,0,sizeof(ia));     // 暂存乘法运算的结果

     reverse(str1.begin(), str1.end());     // 倒置
     reverse(str2.begin(), str2.end());

     int point1, point2,point;               //     小数位数
     point1 = str1.find('.');    
     point2 = str2.find('.');
     if(point1 != string::npos)               // 如果为小数,则将小数点删除
          str1.erase(str1.begin()+point1);
     else
          point1 = 0;
     if(point2 != string::npos)
          str2.erase(str2.begin()+point2);
     else
          point2 = 0;
     point1 > point2 ? point = point1 : point = point2;     // point保存最大的小数位数

     int len1 = str1.size();
     int len2 = str2.size();
    
     for(i = 0; i < len1; i++)               // 乘法运算
          for(j = 0; j < len2; j++)
               ia[i+j] += (str1[i]-'0')*(str2[j]-'0');

     int len;     // 乘积的长度
     for(i = 0; i < len1+len2; i++)          // 进位处理
     {
          if(ia[i] >= 10)
          {
               ia[i+1] += (ia[i]/10);
               ia[i] %= 10;
          }
     }
     if(ia[len1+len2-1] > 0)
          len = len1+len2;
     else
          len = len1+len2-1;

     for(i = len-1; i >= 0; i--)
          result += char(ia[i]+'0');
     if(point > 0)          // 插入小数点
     {
          result.insert(result.end()-point1-point2,'.');
          for(i = result.size()-1; i >= 0; i--)     // 去除小数点后的后置0
          {
               if(result[i] == '0')
                    result.erase(result.begin()+i);
               else if(result[i] == '.')
			   {
				   result.erase(result.begin()+i);
				   break;
			   }
			   else
                    break;
          }
		  while( (*result.begin()) == '0' )		// 去除小数点前的前置0
			  result.erase(result.begin());
     }
     return result;
}

int main()
{
     //ifstream cin("E:\\vcpp\\test.txt");
    
     string str1;
	 int n;
     while(cin >> str1 >> n)
     {
		 string str2("1");
		 while(n--)
		 {
           str2 = subF(str1, str2);
		 }
          cout << str2 << endl;
     }
     system("pause");
     return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值