POJ 2080Calendar (求日期水题)


Calendar
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 12413 Accepted: 4512

Description

A calendar is a system for measuring time, from hours and minutes, to months and days, and finally to years and centuries. The terms of hour, day, month, year and century are all units of time measurements of a calender system.  
According to the Gregorian calendar, which is the civil calendar in use today, years evenly divisible by 4 are leap years, with the exception of centurial years that are not evenly divisible by 400. Therefore, the years 1700, 1800, 1900 and 2100 are not leap years, but 1600, 2000, and 2400 are leap years.  
Given the number of days that have elapsed since January 1, 2000 A.D, your mission is to find the date and the day of the week.

Input

The input consists of lines each containing a positive integer, which is the number of days that have elapsed since January 1, 2000 A.D. The last line contains an integer −1, which should not be processed.  
You may assume that the resulting date won’t be after the year 9999.

Output

For each test case, output one line containing the date and the day of the week in the format of "YYYY-MM-DD DayOfWeek", where "DayOfWeek" must be one of "Sunday", "Monday", "Tuesday", "Wednesday", "Thursday", "Friday" and "Saturday".

Sample Input

1730
1740
1750
1751
-1

Sample Output

2004-09-26 Sunday
2004-10-06 Wednesday
2004-10-16 Saturday
2004-10-17 Sunday
 
从2000年1月1日,星期六算 第n天是哪年哪月哪日周几
星期直接 % 7 就可以了
年份呢,从2000累加看看 n里面有几个,注意判断是否闰年
月份和年份的判断一样,函数参数得带个年
日期就是最后剩下的 n+1
 
水题居然交3遍过的,惭愧惭愧,
有一个坑点是 月份和日是两位数
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
char week[7][12] = {"Saturday" ,"Sunday","Monday","Tuesday","Wednesday","Thursday","Friday"};
//char m[12][12] = {"January","February","March","April","May","June","July","Aug}
int year_day(int year)
{
    if( (year % 4 == 0 && (year % 100) ) || year % 400 == 0)
        return 366;
    else
        return 365;
}
int month_day(int year,int month)
{
   if( (year % 4 == 0 && (year % 100) ) || year % 400 == 0)
   {
        if(month == 2)
           return 29;
   }
   else
   {
       if(month == 2)
        return 28;
   }
   if(month == 1 || month == 3 || month == 5 || month == 7 || month == 8 || month == 10 || month == 12)
    return 31;
   else
    return 30;
}
int main()
{
    int n;
    while(scanf("%d",&n) != EOF  && n != -1)
    {
        int year = 2000;
        int month = 1;
        int day = n % 7;

        while( n >= year_day(year))
        {
            n = n - year_day(year);
            year++;

        }
        while(n >= month_day(year,month))
        {
            n -= month_day(year,month);
            month++;
        }
        printf("%d-%02d-%02d %s\n",year,month,n + 1,week[day]);
    }

    return 0;
}

  • 3
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值