sgu 114解题记录

7 篇文章 0 订阅

114. Telecasting station

time limit per test: 0.25 sec. 
memory limit per test: 4096 KB

Every city in Berland is situated on Ox axis. The government of the country decided to build new telecasting station. After many experiments Berland scientists came to a conclusion that in any city citizens displeasure is equal to product of citizens amount in it by distance between city and TV-station. Find such point on Ox axis for station so that sum of displeasures of all cities is minimal.

Input

Input begins from line with integer positive number N (0<N<15000) – amount of cities in Berland. Following N pairs (XP) describes cities (0<X, P<50000), where X is a coordinate of city and P is an amount of citizens. All numbers separated by whitespace(s).

Output

Write the best position for TV-station with accuracy 10-5.

Sample Input

4
1 3
2 1
5 2
6 2

Sample Output

3.00000
题目链接:http://acm.sgu.ru/problem.php?contest=0&problem=114

题目大意:

      百慕大的每一座城市都坐落在一维直线上。这个国家的政府决定建造一个新的广播电视台。经过了许多次试验后,百慕大的科学家们提出了一个结论,在每座城市的不满意度等于这座城市的市民数与这座城市与广播电视台的距离的乘积。找到这个一维直线上的一点来建造广播电视台,使得所有城市的不满意度的和最小。

解题记录:

        裸的带权中位数

        sub1 AC 31ms 230kb

解题报告:

         带权中位数

代码:

#include <cstdio>
#include <algorithm>

using namespace std;

struct typ1{
	double x;
	int p;
}a[15010];

int n, sum=0;

bool cmp(typ1 a, typ1 b) {
	return (a.x < b.x)? true:false;
}

void init() {
	scanf("%d", &n);
	for (int i = 1; i <= n; i++) {
		scanf("%lf%d", &a[i].x, &a[i].p);
		sum += a[i].p;
	}
	sort(a+1, a+n+1, cmp);
}

void solve() {
	sum = sum/2+1;

	int tmp=0;
	for (int i = 1; i <= n; i++) {
		tmp += a[i].p;
		if (tmp >= sum) {
			printf("%.5lf\n", a[i].x);
			return;
		}
	}
}

int main() {
	init();
	solve();
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值