centos 安装python3.5.2

原创 2016年08月31日 13:15:41

本文以安装python3.5.2为例子


1、从python官网下载

wget https://www.python.org/ftp/python/3.5.2/Python-3.5.2.tgz

 

2、解压Python-3.5.2.tgz

tar xzf Python-3.5.2.tgz

 

3、配置编译安装python3

 

安装python需要的库

yum -y install gcc gcc-c++ openssl-devel bzip2-devel expat-devel gdbm-devel readline-devel sqlite-devel


cd Python-3.5.2/

 

进行配置,把安装的python​3.5.2的目录放到/usr/local/python3.5里面

./configure --prefix=/usr/local/python3

 

完成后执行echo $?返回是0则配置没有错误,继续进行下一步编译

make -j2

 

完成后执行echo $?返回是0则编译没有错误,继续进行下一步​安装

make install -j2

 

ls /usr/local/python3/bin/python3.5

看到有这个文件,则用软链接的形式添加到变量里面

ln -s /usr/local/python3/bin/python3.5 /usr/bin/python3


ls /usr/local/python3/bin/pip3

这里会出现两种情况,如果有这个文件,则直接到(2):

1)如果提示没有这个文件,则需要把pip3编译安装上去

wget https://pypi.python.org/packages/11/b6/abcb525026a4be042b486df43905d6893fb04f05aac21c32c638e939e447/pip-9.0.1.tar.gz#md5=35f01da33009719497f01a4ba69d63c9 -O pip-9.0.1.tar.gz

tar xzf pip-9.0.1.tar.gz

cd pip-9.0.1/

python3 setup.py install

 

如果出现以下提示:

Traceback (mostrecent call last):

  File "setup.py", line 6, in<module>

    from setuptools import setup, find_packages

ImportError: Nomodule named setuptools

 

则需要先安装setuptools,再安装pip

wget https://pypi.python.org/packages/a0/85/24d3b6b331b056180f28ce19658a515364dca58aa9e88eff2ac39bf825f2/setuptools-25.0.0.tar.gz#md5=615d7c98ea77f816a72d0d1f4401f311 -O setuptools-25.0.0.tar.gz

tar xzf setuptools-25.0.0.tar.gz

cd setuptools-25.0.0/

python3 setup.py install

 

最后提示Finished processing dependencies forsetuptools==25.0.0

则安装setuptools成功

 

再回去pip-9.0.1目录

执行python3 setup.py install安装

最后提示Finished processing dependencies for pip==9.0.1

pip安装成功

ls查看确认

ls /usr/local/python3/bin/pip3

 

2)提示有这个文件,则用软链接的形式添加到变量里面

ln -s /usr/local/python3/bin/pip3 /usr/bin/pip3

 

4、验证安装

 

输入python3命令,出现以下则成功

Python 3.5.2(default, Aug 31 2016, 07:34:34)

[GCC 4.8.5 20150623(Red Hat 4.8.5-4)] on linux

Type"help", "copyright", "credits" or"license" for more information.

>>>

 

输入pip3 -V命令,出现以下则成功

pip 8.1.1 from /usr/local/python3/lib/python3.5/site-packages (python 3.5)

版权声明:本文为博主原创文章,未经博主允许不得转载。

CentOS6 安装Python3.5 原来是python2.6 升级到python3s

装了CentOS 6.7,想搭载Python3, 期间遇到这样一个big问题,第5步解压的时候,tar解压出错: gzip: stdin: not in gzip format  tar: Child...

Centos 7 安装 Python3.5.2后yum不能正常使用的解决办法

Centos 7后自帶Python2.7.5, 考慮到 Python3更新的內容比較多,于是安裝 Python3.5.2 來學習, 搭建了一個測試網站(hello.py) 后發現后臺還是以 Pytho...
  • degrade
  • degrade
  • 2016年10月14日 11:58
  • 2679

centOS7中将Python2.7.5 升级到Python3.5.2

第1步:更新gcc,gcc版本太老会导致新版本python包编译不成功复制代码代码如下:yum -y install gcc 系统会自动下载并安装或更新,等它自己结束第2步:下载Python3.5.2...

windows 上面python3.5.2安装一些模块。

安装环境安装numpy模块建议官网下载安装http://www.lfd.uci.edu/~gohlke/pythonlibs/(这个网址重要,包含很多需要的python库文件,),numpy是一个基础...
  • JQ_AK47
  • JQ_AK47
  • 2017年01月17日 14:50
  • 1219

win10下python(3.5.2)和tensorflow安装环境搭建

在win10环境下搭建python3.5.2和tensorflow平台 操作步骤如下: 1、  官网(https://www.python.org/ )下载python3.5.2           ...
  • wsf09
  • wsf09
  • 2017年12月10日 15:29
  • 41

Python 3.5.2 - PyQt5 - eric6安装指南

Python 3.5.2(x32) 是目前兼容较好的版本,可以搭配 PyQt5 的界面设计以及 eric6 的整合编程平台,达到不错的编程体验。建议64-bit用户下载32-bit Python,减少...
  • s0s1970
  • s0s1970
  • 2017年01月16日 17:58
  • 218

python-3.5.2安装Django-1.8.17

一、下载Django-1.8.17.tar.gz https://www.djangoproject.com/download/ 对于Django,他是依赖于Python版本:2.7, p...

Windows10下python3.5.2+CUDA8.0+TensorFlow安装日记

Windows10 64位下配置TensorFlow with GPU support 安装日记 包括Python3.5.2、 Ipython、 Python IDE、CUDA8.0安装、 cuDNN...
  • Suo_ivy
  • Suo_ivy
  • 2017年04月04日 17:37
  • 1975

cygwin2.6_x86编译安装python3.5.2

一、环境: win7 babun 1.2.0 cygwin 2.6.0 二、下载wget https://www.python.org/ftp/python/3.5.2/Python-3.5.2...

Python3.5.2安装pycairo续

上回书说到,给python3.5编译安装pycairo时,configure阶段卡住了。今天终于搞定
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:centos 安装python3.5.2
举报原因:
原因补充:

(最多只允许输入30个字)