2015 ACM/ICPC Asia Regional Changchun Online(1007)

The Water Problem

Time Limit: 1500/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)

Problem Description
In Land waterless, water is a very limited resource. People always fight for the biggest source of water. Given a >sequence of water sources with a1,a2,a3,…,an representing the size of the water source. Given a set of queries each >containing 2 integers l and r, please find out the biggest water source between al and ar.

Input
First you are given an integer T(T≤10) indicating the number of test cases. For each test case, there is a number >n(0≤n≤1000) on a line representing the number of water sources. n integers follow, respectively a1,a2,a3,…,an, and >each integer is in {1,…,106}. On the next line, there is a number q(0≤q≤1000) representing the number of queries. >After that, there will be q lines with two integers l and r(1≤l≤r≤n) indicating the range of which you should find out >the biggest water source.

Output
For each query, output an integer representing the size of the biggest water source.

Sample Input
3
1
100
1
1 1
5
1 2 3 4 5
5
1 2
1 3
2 4
3 4
3 5
3
1 999999 1
4
1 1
1 2
2 3
3 3

Sample Output
100
2
3
4
4
5
1
999999
999999
1

简单的模拟题

#include<iostream>
#include<cstring>
#include<algorithm>
#include<vector>
#include<queue>
#include<map>
#include<cstdio>
using namespace std;

int a[2222];

int main(void)
{
    int T;
    int n, q;
    scanf("%d", &T);
    while(T--)
    {
        scanf("%d", &n);
        int i, j;
        for(i = 1; i <= n; i++)
            scanf("%d", &a[i]);
        scanf("%d", &q);
        int l, r;
        while(q--)
        {
            scanf("%d%d", &l, &r);
            int MAX = a[l];
            for(i = l+1; i <= r; i++)
                MAX = max(MAX, a[i]);
            printf("%d\n", MAX);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值