Matrix Multiplication解题报告

题目摘要:Johnny and John are good friends.Johnny is going to take the entrance exams for postgraduate schools.

Recently, he is reviewing Linear Algebra.Johnny always says that he is very skillful at matrix

multiplication. As we all know that, if weknow matrix a (m rows and n columns) and b (n rows and t

columns), the result matrix c (m rows and tcolumns) can be calculated by expression c (i, j) =(1<= i<= m, 1 <= j <= t). But John wants to make things difficult. He wantsJohnny to calculate matrix c using expression c (i, j) =(1<= i <= m, 1 <= j<= t, i + k is odd and k +j is even). We consider that 2 is odd and even. Atthe beginning, c (i, j) =0.

题目大意:重新定义矩阵乘法,在原来的条件下增加了条件,要求i+k是奇数,k+j是偶数时才加上。并且规定,2既是奇数又是偶数。

输入输出要求

Input

The first line of input is the number T oftest case.

The first line of each test case containsthree integers, m, n, t, indicates the size of the matrix a and b. We alwaysassume that the rows of matrix a equals to matrix b's columns.

The next m lines describe the matrix a.Each line contains n integers.

Then n lines followed, each line contains tintegers, describe the matrix b.

1<= T <= 10, 1 <= m, n, t <=100, 0 <= a (i, j) <= 100, 0 <= b (i, j) <= 100.

 

Output

For each test case output the matrix c. Thenumbers are separated by spaces. There is no space at the end of each line.

输入输出样例

Sample Input

1

2 2 2

1 2

2 3

2 3

3 0

Sample Output

2 0

4 0

解题思路:两个矩阵相乘,3重for循环加上新条件一血AC。

代码

#include<iostream>

#include<cstring>

using namespace std;

 

const int maxn=100+5;

int A[maxn][maxn];

int B[maxn][maxn];

int C[maxn][maxn];

int main()

{

       intT;

       inti,j,k;

       cin>>T;

       while(T--)

       {

              memset(C,0,sizeof(C));

              intm,n,t;

              cin>>m>>n>>t;

              for(i=1;i<=m;i++)

                     for(j=1;j<=n;j++)

                            cin>>A[i][j];

              for(i=1;i<=n;i++)

                     for(j=1;j<=t;j++)

                            cin>>B[i][j];

              for(i=1;i<=m;i++)

                     for(j=1;j<=t;j++)

                            for(k=1;k<=n;k++)

                            {

                                   if((i+k==2)&&((k+j)%2==0))

                                          C[i][j]=C[i][j]+A[i][k]*B[k][j];

                                   else

                                          if(((i+k)%2)&&((k+j)%2==0))

                                                 C[i][j]=C[i][j]+A[i][k]*B[k][j];

                            }

              for(i=1;i<=m;i++)

              {

                     for(j=1;j<=t;j++)

                     {

                            cout<<C[i][j];

                            if(j!=t)

                                   cout<<" ";

                     }

                     cout<<endl;

              }

       }

       return0;

}

解题感想:挺简单一题,千万注意There is no space at the end of each line.这句话就好,PE的话就抓狂了

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值