UVA-10935Throwing cards away I

Given is an ordered deck of n cards numbered 1to n with card 1 at the top and card n at thebottom. The following operation is performed aslong as there are at least two cards in the deck:Throw away the top card and movethe card that is now on the top of thedeck to the bottom of the deck.Your task is to find the sequence of discardedcards and the last, remaining card.InputEach line of input (except the last) contains anumber n ≤ 50. The last line contains ‘0’ andthis line should not be processed.OutputFor each number from the input produce twolines of output. The first line presents the sequenceof discarded cards, the second line reportsthe last remaining card. No line will haveleading or trailing spaces. See the sample for theexpected format.Sample Input7191060Sample OutputDiscarded cards: 1, 3, 5, 7, 4, 2Remaining card: 6Discarded cards: 1, 3, 5, 7, 9, 11, 13, 15, 17, 19, 4, 8, 12, 16, 2, 10, 18, 14Remaining card: 6Discarded cards: 1, 3, 5, 7, 9, 2, 6, 10, 8Remaining card: 4Discarded cards: 1, 3, 5, 2, 6Remaining card: 4
#include <iostream>
#include<cstdio>
#include<cstring>
#include<string.h>
#include<string>
#include<stdio.h>
#include<algorithm>
#include<queue>
using namespace std;
int main()
{
    int b[51];
    int i,j;
    int n;
    int l;
    int s1;
    queue<int> a;
    while(scanf("%d",&n),n!=0)
    {
        for(i=1; i<=n; i++)
            a.push(i);
        i=0;
        l=a.size();
        while(l>=2)
        {
            b[i]=a.front();
            a.pop();
            s1=a.front();
            a.push(s1);
            a.pop();
            i++;
            l=a.size();
        }
        printf("Discarded cards:");
        for(j=0; j<i; j++)
        {
            if(j==0)
                printf(" %d",b[j]);
            else
                printf(", %d",b[j]);
        }
        printf("\n");
        printf("Remaining card: %d\n",a.front());
        a.pop();
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值