优先队列(堆)poj1442Black Box

题目描述

Our Black Box represents a primitive database. It can save an integer array and has a special i variable. At the initial moment Black Box is empty and i equals 0. This Black Box processes a sequence of commands (transactions). There are two types of transactions:

ADD (x): put element x into Black Box;
GET: increase i by 1 and give an i-minimum out of all integers containing in the Black Box. Keep in mind that i-minimum is a number located at i-th place after Black Box elements sorting by non- descending.

Let us examine a possible sequence of 11 transactions:

Example 1

N Transaction i Black Box contents after transaction Answer 
      (elements are arranged by non-descending)   
1 ADD(3)      0 3   
2 GET         1 3                                    3 
3 ADD(1)      1 1, 3   
4 GET         2 1, 3                                 3 
5 ADD(-4)     2 -4, 1, 3   
6 ADD(2)      2 -4, 1, 2, 3   
7 ADD(8)      2 -4, 1, 2, 3, 8   
8 ADD(-1000)  2 -1000, -4, 1, 2, 3, 8   
9 GET         3 -1000, -4, 1, 2, 3, 8                1 
10 GET        4 -1000, -4, 1, 2, 3, 8                2 
11 ADD(2)     4 -1000, -4, 1, 2, 2, 3, 8   

It is required to work out an efficient algorithm which treats a given sequence of transactions. The maximum number of ADD and GET transactions: 30000 of each type.

Let us describe the sequence of transactions by two integer arrays:

  1. A(1), A(2), …, A(M): a sequence of elements which are being included into Black Box. A values are integers not exceeding 2 000 000 000 by their absolute value, M <= 30000. For the Example we have A=(3, 1, -4, 2, 8, -1000, 2).

  2. u(1), u(2), …, u(N): a sequence setting a number of elements which are being included into Black Box at the moment of first, second, … and N-transaction GET. For the Example we have u=(1, 2, 6, 6).

The Black Box algorithm supposes that natural number sequence u(1), u(2), …, u(N) is sorted in non-descending order, N <= M and for each p (1 <= p <= N) an inequality p <= u§ <= M is valid. It follows from the fact that for the p-element of our u sequence we perform a GET transaction giving p-minimum number from our A(1), A(2), …, A(u§) sequence.

输入描述

Input contains (in given order): M, N, A(1), A(2), …, A(M), u(1), u(2), …, u(N). All numbers are divided by spaces and (or) carriage return characters.

输出描述

Write to the output Black Box answers sequence for a given sequence of transactions, one number each line.

样例输入 1 

7 4
3 1 -4 2 8 -1000 2
1 2 6 6

样例输出 1 

3
3
1
2

题目意思就是

给定M个数,每次可以插入序列一个数;再给N个数,表示在插入第几个数时输出一个数,第一次输出序列中最小的,第二次输出序列中第二小的……以此类推,直到输出N个数

思路:首先要知道的就是我们需要运用一下STL容器,因为我们发现需要对数组的数进行排序,而一些STL容器是可以自动帮忙实现排序的,其次我们发现要找到第n小的数,起初我的思路是直接在数组中查询,但很明显,会TLE,转头我想到既然是第n小的数,我可以把一个数组分为两部分,一部分是比n大的数,一部分是比n小的数,也就是创建两个优先队列,p1是最大值优先,p2是最小值优先,而优先队列是默认最大值优先的,所以我们就单独更改一下p2就行,然后最关键的步骤其实是在输出第n小的值后,注意我们需要将这个数放到p1中,原因是我们需要将目光放到第n个最小的数后面,也就是p2队列,所以需要将第n个数放到p1队列中

具体代码如下

#include<iostream>
#include<queue>
using namespace std;
priority_queue<int,vector<int>,greater<int> >p2;
priority_queue<int,vector<int>>p1;
int a[1000000];

int main(){
    int m,n,x;
    cin>>m>>n;
    int cnt=1;
    for(int i=1;i<=m;i++){
        cin>>a[i];
    }
   for(int i=1;i<=n;i++){
       cin>>x;
       while(cnt<=x){
           if(!p1.empty()&&a[cnt]<p1.top()){
               p2.push(p1.top());
               p1.pop();
               p1.push(a[cnt]);
           }
           else{
               p2.push(a[cnt]);
           }
           cnt++;
       }
       cout<<p2.top()<<endl;
       p1.push(p2.top());
       p2.pop();
} 
    
    
    
    
    
    
    
    return 0;
}

  • 25
    点赞
  • 17
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值