pSort

pSort

题面翻译

题目描述

给定一个长度为 n n n 的数列 { a n } \{a_n\} {an},初始时 { a n } = { 1 , 2 , … , n } \{a_n\} = \{1, 2, \dots, n\} {an}={1,2,,n}。位置 i i i 上的数可以和位置 i ± d i i \pm d_i i±di 上的数交换。给定一个 1 ∼ n 1 \sim n 1n 的全排列,问初始的数列可否交换成给定的形式。

输入格式

第一行一个整数 n n n

第二行 n n n 个互不相同的整数表示目标数列。

第三行 n n n 个整数表示 d 1 , d 2 , … , d n d_1, d_2, \dots, d_n d1,d2,,dn

输出格式

如果能交换到给定样式,输出 YES,否则输出 NO

数据范围

1 ≤ n ≤ 100 1 \le n \le 100 1n100

题目描述

One day $ n $ cells of some array decided to play the following game. Initially each cell contains a number which is equal to it’s ordinal number (starting from $ 1 $ ). Also each cell determined it’s favourite number. On it’s move $ i $ -th cell can exchange it’s value with the value of some other $ j $ -th cell, if $ |i-j|=d_{i} $ , where $ d_{i} $ is a favourite number of $ i $ -th cell. Cells make moves in any order, the number of moves is unlimited.

The favourite number of each cell will be given to you. You will also be given a permutation of numbers from $ 1 $ to $ n $ . You are to determine whether the game could move to this state.

输入格式

The first line contains positive integer $ n $ ( $ 1<=n<=100 $ ) — the number of cells in the array. The second line contains $ n $ distinct integers from $ 1 $ to $ n $ — permutation. The last line contains $ n $ integers from $ 1 $ to $ n $ — favourite numbers of the cells.

输出格式

If the given state is reachable in the described game, output YES, otherwise NO.

样例 #1

样例输入 #1

5
5 4 3 2 1
1 1 1 1 1

样例输出 #1

YES

样例 #2

样例输入 #2

7
4 3 5 1 2 7 6
4 6 6 1 6 6 1

样例输出 #2

NO

样例 #3

样例输入 #3

7
4 2 5 1 3 7 6
4 6 6 1 6 6 1

样例输出 #3

YES

思路:对于每一个数,想要到达它原来的位置的话,我们应该能够确保它们在一个连通块内,只有这样才能够到达目标位置,因此我们可以想到利用并查集,最后判断i与fa[a[i]]是否一样即可

AC代码:

#include<bits/stdc++.h>

using namespace std;

typedef long long ll;
typedef pair<int, int>PII;
const int MOD = 998244353;
const int N = 4e5 + 10;

int dx[] = {0, 0, 1, -1};
int dy[] = {1, -1, 0, 0};


int fa[110];
int a[110];
int d[110];
int finds(int x)
{
	if(x != fa[x]) fa[x] = finds(fa[x]);
	return fa[x];
}

void un(int x, int y)
{
	int o1 = finds(x), o2 = finds(y);
	if(o2 != o1) 
	{
		fa[o2] = fa[o1];
	}
}
int main()
{
	int n;
		cin >> n;
		for(int i = 1; i <= n; i ++) fa[i] = i;
		for(int i = 1; i <= n; i ++) cin >> a[i];
		for(int i = 1; i <= n; i ++) cin >> d[i];
		for(int i = 1; i <= n; i ++)
		{
			if(i > d[i]) un(i, i - d[i]);
			if(i + d[i] <= n) un(i, i + d[i]);
		}
		int f = 0;
		for(int i = 1; i <= n; i ++)
		{
			if(finds(i) != finds(a[i]))
			{
				f = 1;
				break;
			}
		}
		if(f) puts("NO");
		else puts("YES");
}
import time import openpyxl from selenium import webdriver from bs4 import BeautifulSoup # 设置请求头,模拟真实浏览器访问 headers = { 'User-Agent': 'Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/88.0.4324.182 Safari/537.36', } # 使用Selenium启动浏览器 driver = webdriver.Chrome() data = [] counter = 1 # 序列号计数器 # 打开网页 for i in range(1,6): url = 'https://search.jd.com/Search?keyword=%E6%89%8B%E6%9C%BA&psort=3&wq=%E6%89%8B%E6%9C%BA&psort=3&pvid=0faa3ec65d444d68a66161cdf464d451&psort=3&page={}&s=61&click=0'.format( (i * 2) - 1) driver.get(url) # 模拟滚动页面,以触发异步请求加载更多商品信息 driver.execute_script('window.scrollTo(0, document.body.scrollHeight);') time.sleep(2) # 获取完整页面内容 html = driver.page_source # 解析网页内容,提取商品名称和价格信息 soup = BeautifulSoup(html, 'html.parser') products = soup.select('.gl-item') for product in products: product_id = product['data-sku'] # 提取产品ID name = product.select('.p-name em')[0].text.strip() product_url = 'https:' + product.select('.p-name a')[0]['href'] # 修改产品URL price = product.select('.p-price strong i')[0].text.strip() data.append([counter, product_id, name, product_url, price]) # 将产品数据添加到列表中 counter += 1 # 每个产品的增量计数器 # 关闭浏览器 driver.quit() # 创建Excel文件并保存数据 wb = openpyxl.Workbook() ws = wb.active ws.append(['top', '商品ID', '商品名称', '商品链接', '价格']) # 添加已修改列顺序的标题行 for item in data: ws.append(item) wb.save('jd_top300.xlsx') print("数据已保存到jd_top300.xlsx文件。")
06-02
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值