1002 A+B for Polynomials 浙大PTA1002

 

1002 A+B for Polynomials (25 分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

 主要面对新手超详细教程 
 新手不要恐惧,很简单 

 

//思路:
//1.把两个多项式分别放到链表里
//2.然后分别取出进行指数比较,相等就系数相加(但要注意系数得0时)
//如果其中某一个大于另一个的指数则直接push到结果链表里
//3.当完成之后,如果还有不为空的链表直接添加到结果链表里 
//4.最后输出 

#include<cstdio>
#include<list>
using namespace std;

typedef struct polynomials{
    int expon;//指数 
    double coef;//系数 
}Polynomials;


list<Polynomials> ploAdd(list<Polynomials> p1,list<Polynomials> p2){
    list<Polynomials> result;
    
    while(p1.size()!=0 && p2.size() != 0){
        //当指数相等时系数直接相加 
        if(p1.front().expon == p2.front().expon){
            //注意当系数为0时不应该加入到result里 
            if(p1.front().coef + p2.front().coef != 0){
                p1.front().coef += p2.front().coef;
                result.push_back(p1.front());
            }
        
            p1.pop_front();
            p2.pop_front();
        }
        //当p1的首元素大于p2的时候 ,直接添加到result 
        else if(p1.front().expon > p2.front().expon){
            result.push_back(p1.front());
            p1.pop_front();
        }
        
        //当p2的首元素大于p1的时候 ,直接添加到result 
        else if(p1.front().expon < p2.front().expon){
            result.push_back(p2.front());
            p2.pop_front();
        }
    }


    //当一个多项式为空时,把另一个拷贝到result 
    while(p1.size() != 0){
        result.push_back(p1.front());
        p1.pop_front();
    }

    while(p2.size() != 0){
        result.push_back(p2.front());
        p2.pop_front();
    }

    return result;
}

//输出 
void show(list<Polynomials> result){
    printf("%d",result.size());
    for(list<Polynomials>::iterator it = result.begin();it != result.end();it++){
        printf(" %d %.1lf",it->expon,it->coef);
    }
}

int main()
{
    //初始化两个链表 
    list<Polynomials> p1;
    list<Polynomials> p2;
    int n,inCount;

    int expon;
    double coef;
    inCount = 2;
    scanf("%d",&n);
    while(n--){
        scanf("%d%lf",&expon,&coef);
        polynomials p;
        p.expon = expon;
        p.coef = coef;
        p1.push_back(p);
    }
    scanf("%d",&n);
    while(n--){
        scanf("%d%lf",&expon,&coef);
        polynomials p;
        p.expon = expon;
        p.coef = coef;
        p2.push_back(p);
    }

    //调用 
    list<Polynomials> p = ploAdd( p1, p2);
    show(p);

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值