【贪心】 hdu1789 Doing Homework again

6 篇文章 0 订阅

Doing Homework again

http://acm.hdu.edu.cn/showproblem.php?pid=1789



Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
  
  
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
  
  
0 3 5

贪心,但是要有些修正。

先按日期从小到大排序,日期相同的按分数从大到小排序。

但这样的排序是有问题的,在计算中还需要修正。

从头处理,判断当前作业能不能完成,用标记数组表示第i个作业在哪天完成。

如果能完成,day++。

如果不能完成,判断在此前是否存在分数小于当前作业的作业,存在则不完成之前的换成完成当前的。(数据可能弱了,不需要判断之前分数最小的作业完成的时候是否在当前作业必须完成作业日期之前)


#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int flag[1005];
struct node
{
    int deadline,reduce;
}num[1005];
bool cmp(const struct node &a,const struct node &b)
{
    return a.deadline!=b.deadline?(a.deadline<b.deadline):(a.reduce>b.reduce);
}
int main()
{
    int T,n;
    scanf("%d",&T);
    for(;T--;)
    {
        scanf("%d",&n);
        memset(flag,-1,sizeof(flag));
        for(int i=0;i<n;++i)
            scanf("%d",&num[i].deadline);
        for(int i=0;i<n;++i)
            scanf("%d",&num[i].reduce);
        sort(num,num+n,cmp);
        int day=0,minn,xi,maxx=0;
        for(int i=0;i<n;++i)
        {
            if(day<num[i].deadline)
            {
                flag[i]=day;
                day++;
            }
            else
            {
                minn=(1<<30)-1;
                for(int j=0;j<i;++j)
                {
                    if(flag[j]!=-1&&flag[j]<num[j].deadline&&minn>num[j].reduce)
                    {
                        minn=num[j].reduce;
                        xi=j;
                    }
                }
                if(minn<num[i].reduce)
                {
                    flag[i]=flag[xi];
                    flag[xi]=-1;
                    maxx+=num[xi].reduce;
                }
                else
                    maxx+=num[i].reduce;
            }
        }
        printf("%d\n",maxx);
    }
    return 0;
}
来源: http://blog.csdn.net/acm_ted/article/details/7772145

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值