1015 Reversible Primes

21 篇文章 0 订阅
13 篇文章 0 订阅

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<10​5​​) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

AC代码:(素数+进制转换(转化为十进制))

 #include <iostream>
#include <bits/stdc++.h>
using namespace std;
int p[(int)1e7+10];
void prime()
{
    p[0] = 1;
    p[1] = 1;
    for(int i=2; i<=(int)1e7+10; i++)
    {
        if(p[i]==0)
        {
            for(int j=i+i; j<=(int)1e7+10; j=j+i)
            {
                p[j] = 1;
            }
        }
    }
}
int main()
{
    prime();
    int n,d;
    queue<int>q;
    while(~scanf("%d%d",&n,&d))
    {
        if(n<0)
            break;
        if(p[n]==0)
        {
            int m = n;
            while(m)
            {
                q.push(m%d);
                m = m / d;
            }
            int s = 0;
            while(!q.empty())
            {
                s=s*d+q.front();
                q.pop();
            }
           // printf("%d\n",s);
            if(p[s]==0)
            {
                printf("Yes\n");
            }
            else
            {
                printf("No\n");
            }
        }
        else
        {
            printf("No\n");
        }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值