【poj 1451】T9 (字典树+深搜)

D - T9
Time Limit:1000MS Memory Limit:10000KB 64bit IO Format:%I64d & %I64u

Submit

Status

Description

Background

A while ago it was quite cumbersome to create a message for the Short Message Service (SMS) on a mobile phone. This was because you only have nine keys and the alphabet has more than nine letters, so most characters could only be entered by pressing one key several times. For example, if you wanted to type “hello” you had to press key 4 twice, key 3 twice, key 5 three times, again key 5 three times, and finally key 6 three times. This procedure is very tedious and keeps many people from using the Short Message Service.

This led manufacturers of mobile phones to try and find an easier way to enter text on a mobile phone. The solution they developed is called T9 text input. The “9” in the name means that you can enter almost arbitrary words with just nine keys and without pressing them more than once per character. The idea of the solution is that you simply start typing the keys without repetition, and the software uses a built-in dictionary to look for the “most probable” word matching the input. For example, to enter “hello” you simply press keys 4, 3, 5, 5, and 6 once. Of course, this could also be the input for the word “gdjjm”, but since this is no sensible English word, it can safely be ignored. By ruling out all other “improbable” solutions and only taking proper English words into account, this method can speed up writing of short messages considerably. Of course, if the word is not in the dictionary (like a name) then it has to be typed in manually using key repetition again.

Figure 8: The Number-keys of a mobile phone.

More precisely, with every character typed, the phone will show the most probable combination of characters it has found up to that point. Let us assume that the phone knows about the words “idea” and “hello”, with “idea” occurring more often. Pressing the keys 4, 3, 5, 5, and 6, one after the other, the phone offers you “i”, “id”, then switches to “hel”, “hell”, and finally shows “hello”.

Problem

Write an implementation of the T9 text input which offers the most probable character combination after every keystroke. The probability of a character combination is defined to be the sum of the probabilities of all words in the dictionary that begin with this character combination. For example, if the dictionary contains three words “hell”, “hello”, and “hellfire”, the probability of the character combination “hell” is the sum of the probabilities of these words. If some combinations have the same probability, your program is to select the first one in alphabetic order. The user should also be able to type the beginning of words. For example, if the word “hello” is in the dictionary, the user can also enter the word “he” by pressing the keys 4 and 3 even if this word is not listed in the dictionary.

Input

The first line contains the number of scenarios.

Each scenario begins with a line containing the number w of distinct words in the dictionary (0<=w<=1000). These words are iven in the next w lines in ascending alphabetic order. Every line starts with the word which is a sequence of lowercase letters from the alphabet without whitespace, followed by a space and an integer p, 1<=p<=100, representing the probability of that word. No word will contain more than 100 letters.

Following the dictionary, there is a line containing a single integer m. Next follow m lines, each consisting of a sequence of at most 100 decimal digits 2�, followed by a single 1 meaning “next word”.

Output

The output for each scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1.

For every number sequence s of the scenario, print one line for every keystroke stored in s, except for the 1 at the end. In this line, print the most probable word prefix defined by the probabilities in the dictionary and the T9 selection rules explained above. Whenever none of the words in the dictionary match the given number sequence, print “MANUALLY” instead of a prefix.

Terminate the output for every number sequence with a blank line, and print an additional blank line at the end of every scenario.

Sample Input

2
5
hell 3
hello 4
idea 8
next 8
super 3
2
435561
43321
7
another 5
contest 6
follow 3
give 13
integer 6
new 14
program 4
5
77647261
6391
4681
26684371
77771

Sample Output

Scenario #1:
i
id
hel
hell
hello

i
id
ide
idea

Scenario #2:
p
pr
pro
prog
progr
progra
program

n
ne
new

g
in
int

c
co
con
cont
anoth
anothe
another

p
pr
MANUALLY
MANUALLY

题意:
Roney’s blog~

T9 poj 1451 hdu 1298

题意:9宫格模拟手机输入单词。
具体就是给你一些单词,以及该单词被使用的频数,这个频数也是该单词前缀的使用频数,然后再给你一些数字串,让你针对该数字串的每一个前缀输出它的最有可能对应的单词(即频数最大的字符串)。
思路:
*1.按9格建树
2.按传统字母建树;(dfs遍历后存入ans【】【】;离线输出;)

#include<iostream>
#include<stdio.h>
#include<vector>
#include<algorithm>
#include<string.h>
using namespace std;
struct node {
    //int flag;
    int son[27];
    int sum;
}t[100*1000+5];
char ans[105][105];
int sum[27];
int n,m;
int tot;
int vis[205];
char tp[105];
int len; 
char di[10][5]={{'\0'},{'\0'},{"abc"},{"def"},{"ghi"},{"jkl"},{"mno"},{"pqrs"},{"tuv"},{"wxyz"}};
char s[205];
int flag; 


void insert(char s[],int val)
{
    if(val==0) return ;
    int now=0;
    for (int i=0;i<strlen(s);i++)
    {
        int x=s[i]-'a';
        int tt=t[now].son[x];
        if (tt==0)  t[now].son[x]=++tot;
        now=t[now].son[x];
        t[now].sum+=val;
    }   

}
void dfs(int now,int dep)
{       
    if(dep==len+1) return;
    int tmp=s[dep]-'0';
    int L=strlen(di[tmp]);
    for(int i=0;i<L;i++)
    {
        int z=t[now].son[di[tmp][i]-'a'];
        if(z)
        {
            tp[dep]=di[tmp][i];
            tp[dep+1]='\0';
            if((!vis[dep])||t[z].sum>vis[dep])
            {
                vis[dep]=t[z].sum;       
                strcpy(ans[dep],tp);
            }
            dfs(z,dep+1);
        }

    }

}
int main()
{   
        int T;
        scanf("%d",&T);
        for(int pp=1;pp<=T;pp++)
        {   
            printf("Scenario #%d:\n",pp);
            tot=0;
            memset(t,0,sizeof(t));
            scanf("%d",&n);
            for(int j=1;j<=n;j++) 
            {
                int aa;
                scanf("%s%d",s,&aa);
                insert(s,aa);   
            }    
            scanf("%d",&m);
            while(m--)
            {
                memset(vis,0,sizeof(vis));
                scanf("%s",s);
                len=strlen(s);
                len-=2;
                dfs(0,0);
                for(int i=0;i<=len;i++)
                if(vis[i])printf("%s\n",ans[i]);
                else printf("MANUALLY\n");
                printf("\n");
            }
            printf("\n");
        }
        return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值