HDU 3549 Flow Problem 网络流入门

Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.
 

Input
The first line of input contains an integer T, denoting the number of test cases.
For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000)
Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)
 

Output
For each test cases, you should output the maximum flow from source 1 to sink N.
 

Sample Input
  
  
2 3 2 1 2 1 2 3 1 3 3 1 2 1 2 3 1 1 3 1
 

Sample Output
  
  
Case 1: 1 Case 2: 2


题意 :给出节点数和 各边的容量 求最大流

代码

#include<iostream>
#include<cstdio>
#include<queue>
using namespace std;
int vis[18];                
int map[18][18];                //该边的可行流
int fa[18];                     //父亲节点
int m;                          
bool bfs()
{
	memset(vis,0,sizeof(vis));
	memset(fa,0,sizeof(fa));           //每次寻找增广路径 重置
	int now;
	queue<int>q;
	vis[1]=1;now=1;
	q.push(now);
	while(!q.empty())
	{
		now=q.front();
		q.pop();
		if(now==m)
			return true;
		for(int next=1;next<=m;next++)
		{
			if(vis[next]==0&&map[now][next]!=0)
			{
				q.push(next);
				vis[next]=1;
				fa[next]=now;           //得到父亲节点
			}
		}
	}
	return false;
}
int max_f()
{
	int i;
	int ans=0;
	int min1=999999;
	while(1)
	{
		if(bfs()==false)
			return ans;
		for( i=m;i!=1;i=fa[i])               //从汇点到源点比较出此路径能增加的最大流
		{
			if(map[fa[i]][i]<min1)
				min1=map[fa[i]][i];
		}	
		for( i=m;i!=1;i=fa[i])              //更新该路径每条边的流量
		{
			map[fa[i]][i]-=min1;
			map[i][fa[i]]+=min1;
		}
		ans=ans+min1;
	}
}
int main()
{
	int t,n,a,b,s;
	cin>>t;
	for(int k=1;k<=t;k++)
	{
		memset(map,0,sizeof(map));
		cin>>m>>n;
		while(n--)
		{
			cin>>a>>b>>s;
			map[a][b]+=s;
		}
		cout<<"Case "<<k<<": ";
		cout<<max_f()<<endl;
	}
	return 0;
}

网络流第一种算法:Edmonds-Karp算法

的模板。。。


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值